Sync issue with infuse 5 pro

Since upgrading Infuse 5 Pro a couple versions back (not sure exactly when, definitely the current one and the one before) the audio is out of sync. Sometimes it’s in sync for the first 10-15min and gradually goes out, sometimes it’s noticeably out of sync right away. The ATV4k is connected via gigabit lan to my windows 10 pro machine (also gigabit). When I first purchased Infuse5 pro it was working beautifully. I tried another player and everything plays normally, but I rather like Infuse’s UI and UX a lot more.

I have the same issue, specially when using AirPods.
Pausing for a second and resuming seems to make it less worse, but it’s still very noticeable.

don’t know that I’ve noticed with AirPods. but I also don’t know that I’ve tried. But it would make sense with the delays that bluetooth introduces.

I think bluetooth audio syncing is done by the Apple TV. The delay started to happen after the last couple updates but I don’t know exactly which version.