Support for Filerun/Nextcloud WebDAV

Ok, I’m connecting infuse to my Mac min server using WebDAV. This solution is provided by a web interface called Filerun, which works really great !

The thing is, every time I try to connect to it, I get an HTTP error.
The error is 2552203676.

I put the correct user name and password, the good address, and pointing to a directory on not does nothing.

One point though. To connect to the server, I use :
HTTPS://files.server.com/dav.php

Is it because of the call of a PHP file ?
I saw earlier in another thread that infuse was unable to connect to something like :
…com/wished/directory

For information, the certificate is provided by lets encrypt.

Thanks in advance ! :slight_smile:

2 Likes

I think it would be best to leave off the php file at the end. A saved share in Infuse will load a directory path, and not a specific file.

You can also leave off the https:// portion of the address, as Infuse will add this automatically.

I can’t remove the php file as it is mandatory to call the WebDAV fonction.

Every other app I use to connect to a WebDAV interface needs the php file.

Filerun is based on Nextcloud, so it should do the same.

When calling the PHP file, it replies every information the app request.

I’ve not used webDAV but I was curious if you have tried SMB? The MacOS handles this quite well and it’s real easy to set up.

It’s working well via smb, but not open to the outside, only WebDAV.
I can connect to my server at home, but I want my parents to connect there Apple TV to it too, and there is no other way for my configuration.

FE file explorer works fine, but is not very good as a player.

No answer it seems :confused:
For information, filerun is a fork of nextcloud. So if it’s not working with filerun, it means this is not working with nextcloud either :slight_smile:

I don’t believe this is supported right now, but I’m going to move it over to suggestions and see what we can do.

1 Like

Thanks ! :slight_smile:

I’m sure some people would like to connect there infuse app to a nextcloud or similar (in my case Filerun) cloud storage :slight_smile:

I saw somewhere that the direct path on a WebDAV was on plan. This might actually solve the problem :wink:

Any news on this ? :slight_smile:

It seems not.
So it is still impossible to connect infuse to nextcloud or similar (filerun), or even using a php coded WebDAV server… :confused:

Any updates here ? Thanks

1 Like

Yes please ! :frowning:

Any updates on this ? I am trying to use infuse with webdav and Nextcloud. Thanks

Still no news, and still not possible to do…

Please, everyone, add a like to my post to add this feature, or nothing will happen to this !

I thought WebDAV is officially supported.

Since NextCloud supports WebDAV, why wouldn’t Infuse support NextCloud?

Only partially.

Nextcloud and Owncloud (in my case, filerun as well) are using a php file to generate the WebDAV requests.

So, the real http link is server.com/dav.php.
But infuse is putting dav.php as a location, not as a full link…

Still no news ? It’s starting to get really annoying…
why is every WebDAV client supporting this, except infuse ?!
It’s been 2 years already, and yes, i’m still paying for the subscription since…

@james

This appears to be a non-standard WebDAV implementation that likely requires special handling.

We may be able to get to it at some point, but we’re not seeing a lot of requests for this right now so other tasks are taking priority.

I don’t know if that is the case. But I’m more taking it as a bug rather than a feature here, because all the other WebDAV clients I know, support it, even windows file explorer supports it (which has a really bad WebDAV implementation…).

From my understanding, it’s really just a matter of calling for that PHP file, the rest is just working the same way.

I will just add that next cloud is a very used cloud tool, so it has definitely usefulness to it.

Have you tried setting up WebDAV with TrueNAS? It seems like this may work. I think you can YouTube a tutorial on it.