Sudden Loss of Most Icons - No Wireless or Network Connectivity

I have no idea what happened.  It was working and then it wasn’t.  I suspect someone maybe updated it but everyone denies. 

Apple TV 2, used to run a few of the jailbroken apps and netflix, and now it won’t run anything or connect to the internet anymore.  

It has the few jailbroken related icons and nothing else anymore.  Anyone ever see this before and know what it is?

Network Settings show Ethernet and no longer shows Wi-Fi.  

I’m trying to find out if my wi-fi is fried or if there’s another kind of fix for this.  

I re-jailbroke and restored 5.2.0 with a USB cable and it worked, but now I only have Computers and Settings showing up, and still no Wi-Fi option.  I also have tried using another ATV3 and that shows it all right away.  

Even if I manually enter all the correct IP address info, as long as it says Ethernet and not Wi-Fi this isn’t going to work.  

If anyone has ever heard of anything like this please let me know!

Thank you…

I’ve fixed it.  If anyone else has this issue…

From what I’ve read this usually happens immediately after jailbreaking.  For me it happened many, many MONTHS after, and after working fine for a while.  

Problem: The “Wi-Fi” is completely gone replaced by “Ethernet” and so it can’t connect to the internet and so can’t or won’t display most of the icons.  

Solution: I read that a tethered re-boot will fix it, but I started all over again from scratch, restoring a 5.2.0 image and seeing the same problem after running Seas0nPass.  Once I connected power to the ATV2 and ran a USB cable from the Mac and booting up that way, then replacing the USB cable with the HDMI, the Wi-Fi was restored and I could resume configuring everything else and try to get back to what once was.  Perhaps if I had tried this solution before restoring completely it would have fixed it earlier.  

Not sure if this will remain permanent since the previous situation was supposed to be permanent as well.

After setting everything back up again and manually reconfiguring all settings, the ATV2 lost wifi again.  Can’t boot tethered on 5.2.0 and nothing I try works.  

Anyone have any idea?  

My Jailbroken ATV2 did the same thing. A quick fix that worked for me was to restart Lowtide. You can do this under (NitoTv->Settings->Restart Lowtide). After I restarted Lowtide my wifi connect-ability was restored. I hope this helps…