Successfull jailbreak with Seas0npass - But fail to install updates

Cool, I can successfully jailbreak my 4.2.1 Apple TV2 - but - I saw the Maintainance menu after uploading the lastest software from the Account Download page only after restarting lowtide from the already visible nito Entry in my AppleTV.

Going to the maintainance I see the options, but rying to update the modules I get the following



Couldn't find package com.firecore.lastfm tree


for the PLEX Client

E: unmet dependencies. Try 'apt-get -f install"  -- oops ??



Coldn#t find package com.firecore.couchsurfer

and a test to update nitoTV gives again

E: unmet dependencies ??


Can you say what happens??


Thank You


Any idea?

i have identical problems, none of the packages can be found. Everything else worked as it did before the jailbreak (except its now very slow)


I'm unimpressed and restoring back to the original FW.

If someone could email me when this Beta is over and it actually works then that would be great.

Not complaining, but you really should clearly state that this isnt working properly yet 

Getting the same... James what is up with the install?

I'm getting the same issues except that when I updated nitoTV through its settings menu my "Maintenence" tab completely disappeared!  

Even weirder is that after the successful nitoTV update and loss of the tab is that now I can install packages from nitoTV which I could not at first.... but now I have no access to the menus under Maintenance....

Have you tried to restart Lowtide from the NitoTV menu?

Yes, the tab is still completely missing, no Maintenance whatsoever.

btw. the ABOUT says aTVFlash (black) beta 2

streaming "normal" iTunes song/video works perfect



Edit: and I freshly downloaded the dmg from my Account/Download page

Strange, that`s how I got my normal maintainance menu to become visible at all

And updating the Nito Software from the Nito menu just falls back (luckily)


coool "screenshot"


Is it a server issue on Firecore side... Also I cant get NIto tv to update from anywhere.  Not from maintenance or Nito Tv settings

my nitoTV would not upgrade the first couple times I tried, then once it was successful LowTide restarted to reveal a missing Maint. tab.

same issue here, can't find the packages

Sorry, it's a Seas0nPass bug. New version will be available shortly (check for updates in the Seas0nPass menu).

Once the new version is available you'll need to run through the JB, tethered boot, and aTV Flash (black) install again.

Again, sorry for the trouble.

Thanks for the update, thought I was going crazy for a minute there.


The update should be available within the next hour or so.

yay! Thanks for the hard work

Only installs nito plugin

OK, now got it to go all good until aTV Flash Black. 

Install successful. 

Black screen on TV.  Light on on aTV.  Blinks on remote usage.


I JB with SeasOnpass. I get the same message as you...