Success Story: USB Primary Drive

Good Afternoon! Just this morning I was checking out the AppleTV flash forums and realized that there was now a windows installation process. I did a quick search to verify that I would be able to increase storage space for iTunes syncing by mounting a drive and redirecting the AppleTV directory…

That completed, I purchased and downloaded aTV flash. I used an old 256MB stick from my wife’s company, flashed the aTV, and looked around at the new toys. Internet works, but it’s a bit frustrating because the cursor is slow. Looking forward to upgrading the browser.

I installed XBMC and boxee, took a quick look, but wanted to get to the good stuff. I ran out to radioshack and purchased an iomega 250G external drive, it’s powered solely thru USB. I was concerned that I wouldn’t be able to format it in the required Max OS Extended (Journaled) format, but a bit of research revealed that it’s the same as HFS PLUS (the “journaled” part is automatic I guess, it was a feature added in '02, according to wikipedia). A website called provides a fully functional trial that allowed me to format the drive with the required HFS+ partition. That done, I installed the NitoTV SmartInstaller (required to get USB external drives working), plugged in the new drive, rebooted, and now the ‘About’ screen shows 230+ gigs.

All this took about 6 hours, but that included runs to radioshack, lunch, and a load of rebooting. Also, I noticed that it was trying to re-sync with iTunes after the aTV Flash, so I disabled all syncing from iTunes while I completed the upgrades. The sync definitely slows down everything on the aTV.

So now I’ll sync my library, and start to play with all the other new features. See y’all around!


How did you set the External Hard drive as your primary??? I can’t get it to work. I can access the movies on the external with Sapphire…but that’s it.

You need to follow the instructions from here:

It’s not a trivial process, and you have to login to the guts of the appletv to do it. Use Putty (google search for putty) to login via ssh.

Where exactly are you having the problem?

Hey thanks for the reply, I have tried those instructions but with no luck. I used Terminal to ssh into the ATV but after i rebooted, itunes still said i only had 32GB.

One question:
Instructions, step 6:
6. We will need to link the external drive to where iTunes will look for the primary storage. Replace ‘MYDRIVE’ with your external drive’s name and enter:
sudo ln -s /mnt/Scratch/Volumes/MYDRIVE /mnt/Media

For that step do i just point it to my external hard drive root menu or where my movies are stored. Hope this makes sense!

At step 6 what you’re doing is creating a virtual link. The AppleTV is looking for all the sync files at /mnt/Media. But in the previous step, you renamed /mnt/Media to /mnt/Media.old. The new drive you added will be listed under the /mnt/Scratch/Volume directory. When you ssh in, go to that directory (do you know how to do that?), and find the name of your hard drive; it will be one of the files in that Volume directory. When you formatted the drive you probably had the option to give it a name, and that’s what you need to link to.

To answer the question, at step 6, you give it the name of your external hard drive. NOT the root, and NOT the place where movies are store. The formatted name of the drive.

But I think your problem might be somewhere else… You said that your ATV is still showing 32 gigs. Did you complete the previous step where you did the 'mv /mnt/Media /mnt/Media.old?

Hope I’m being helpful!


Yes, I did every step exactly. Is there anything I could show you to make sure everything is done correctly? Make a copy of my terminal window? By the way I’m on ATV 2.3 if that matters at all.

I really appreciate you trying to help me!

sure! If you can post the output of an ‘ls -al’ from the /mnt/Media directory, I can compare to mine…
It’s a start at least…

Wonderful post!!! I now have a HTF+ USB Hardrive, “TERMINAL” services with putty and all seemed to go so well while on windows.

I followed every step to the letter only I used putty instead of terminal services from the guide. I know I got in and screwed something up because when I rebooted the ATV the Splash screen hung and hung. I pressed menu on my remote and found that the menu popped up but nothing was in it. I hope I didn’t screw the pooch on this one!!! My ATV isn’t accessible any more from the ATV side of things. Again to reiterate, The menu that comes up is completely blank. It’s just a black 2 column table with the ATV logo at top.

Please help, I assume its something minor and I just missed something.

Thanks in advance!!!


Just to let you know, I pulled up the Bash history file on the ATV to show what commands were entered.

they are:

cp -R /mnt/Media/* /mnt/Scratch/Volumes/ATV2
sudo mv /mntMedia /mnt/Media.old
sudo mv /mntMedia /mnt/Media.old
sudo mv /mnt/Media /mnt/Media.old
sudo ln -s /mnt/Scratch/Volumes/ATV2 /mnt/Media
sudo chown -h frontrow:frontrow /mnt/Media
sudo chown -R frontrow:frontrow /mnt/Scratch/Volumes/ATV2
sudo reboot

I was able to make this work but what Im just wondering if there is a way to actually use the external USB drive to store media for ATV Flash. Apparently this mounted drive will only be recognized by the regular ATV apps via iTunes. Maybe Im doing this the wrong way but i actually need the external USB media to compile my favorite DVD’s. The way i have been doing this is just ripping my DVD’s and FTP’ng them to the ATV’s /Movies/DVD folder, which is the internal storage. I have the 160GB ATV but its getting close to 80% now with the VOD and AVI’s I have been uploading to it.

I have a 1 TB USB drive I would like to use to hold my DVD collection… is this doable?

I found out what is going on. The external harddrive works, but interestingly is that if it’s plugged in while the AppleTV reboots it wont read the new XternalHD. I have to wait for the ATV to boot, only then will the new HD be recognized. Anybody know why this is happening? I have a WD 750Gb MyBook. I am guessing that because other people got this to work it must be this particular HD? Anyone with solutions? Thanks

The issue with your Western Digital 750GB USB Hard Drive is it’s built-in power management.

Call up Western Digital and tell them that you are having issues that your hard drive is spinning down while it’s in use, causing issues for you.
They will provide you with a program that will flash it’s firmware and keep it spun up permanently.


Thanks for the info!!! I appreciate it very much. Although interestingly, I didn’t have to do that to fix the problem. I decided to go ahead and update to 2.3.1 and go with the new 3.5.1 ATVFLASH software. After I updated I noticed that the external drive recognized after reboots with out having to detach it. So I went ahead and did the ITunes switch with Putty. It now works wonderfully. I will keep the WD HD fix in mind if it ever comes up again. Thanks a bunch.


Hi guys, I also changed my primary drive to my 1TB external USB drive.

One question remains: I already have a lot of media on this external drive, which I would like to make available for ATV to use.

My drive now looks like this:

bunch of system files

  • Downloads (created by ATV)
  • Media files (created by ATV)
  • Music (my own music files)
  • Video (filled with 800 + video files)[/code]

Is it possible to copy the files from the video and/or music folder somehow so it shows up in ATV menu’s and iTunes?

I’m not sure exactly what you mean… If you want to use the AppleTV native indexing for movies and music, you’ll have to sync it through iTunes. I prefer to use iTunes and the AppleTV native only for music; all my movies and video are accessed with the Files interface provided through ATVFlash…