Subtitles on the NAS not displayed


I use a NAS connected to the network to store and stream movies to the television thru my iPad and a hdmi cable.
Everything is OK, except the display of the subtitles. On the NAS, I have two files for each movie: one .MP4 or .MKV for the movie itself and one .SRT (with the same filename), with the subtitles. When streaming, I can select the movie, but subtitles are not displayed, and do not appear in the section subtitles of the configuration.
Any idea how to fix this ?
I am running Infuse on iOS 8.0.2

No problem here using OS8.1 and Synology NAS. You also (sometimes) have to turn on the subs on your ATV using the menu button

Are you streaming via UPnP?

Some UPnP servers don’t make subtitles available.

A quick way to check this is to browse the share through the Add Files menu (tap + icon from the home screen) and see if the srt files are visible.

If they’re not, you check to see if your NAS supports SMB as this will make all files available, including srt files.

I indeed stream using uPnP , on a Seagate GoFlex Home device; and indeed, I don’t see the .srt file when browsing to the folder, only the .mp4

I’ll try to find the info on the Seagate website, as I can’t find any Samba setting in the configuration of the device itself, but it seems it uses SMB by default …

Nice picture, James :slight_smile:

Yep - that would do it then.

Infuse 3 also supports WebDAV, which should work with srt files as well.

PS - Thanks. :slight_smile: