Subtitles [Airplay]

Hi,

When I airplay any video with subtitles, the subtitles is not showing on the airplay screen. But same video is showing with subtitles on the iPhone / IPad.
Did I miss something ?

Sounds like the video may be zoomed or scaled where the subs are appearing off screen. Just a guess.

No, the video is not zoomed or cropped, subtitles is just not showing

Were these subtitles downloaded from within Infuse?

AirPlay supports a limited number of subtitle types, so it’s possible the subtitles you are using are not compatible with AirPlay.

No it is subtitle encapsulated in the mkv file.

Got it.

Can you try downloading subtitles from within Infuse. These should work just fine over AirPlay.

Just tried with infuse downloaded subtitles but same : showing well on iPhone but not showing over airplay.

Hmmm…

Are you AirPlaying to an Apple TV, or a different type of device?

It’s not an Apple TV. It’s the Philips PicoPix Max.

Ah, that may be the issue as most 3rd party AirPlay devices won’t support subtitles when using AirPlay.

However, we haven’t tried this particular device, so I can’t say for sure.

Have you streamed video with subtitles via AirPlay to this device using apps from Apple or others?

I’m having the same issue here. However the Subtitles are displayed just fine in the first 30min. After that it stops showing suddenly. So I have to stop streaming then stream again.
My movies are in Google Drive, and I’m streaming using AirPlay on my Samsung TV.
It’s weird because every 30min the Subtitles just stops. If the movie is more than 2 Hours long i have to repeat this process 3 or 4 times.
My app is updated. iOS as well

Since you’re seeing the subs at the start is sounds like you may be having a different issue so as to not derail the original posters thread you may want to start a new thread with your different symptoms and also it helps to give the version number of Infuse and os you’re using since both tend to have frequent updates.

Yes I confirm working fine on Apple TV but not on Philips PicoPix Max.

Hi I just got my PicoPix Max and encounter the same issue. Tried few things but I still not exactly sure why some files r working and some are not. I will just share them here anyway to give this post a little push (I have PicoPix Mix software version 1.0.29 & iPhone X on iOS 13.3.1 + Infuse 6):

  • Airplay doesn’t work with subtitles (after 1 or 2 test it even refused to function properly - video plays on iPhone and sound on PicoPix)
  • subtitle able to show on Mirror Screen for some of my video files (x265 mkv with srt subtitle file)

The combinations below are just the collections that I have in my NAS server. I randomly picked it and tried to see if it works (need further testings):

  • subtitle doesn’t show on Mirror Screen when my file is mkv x264
  • my MKV + ASS subtitle doesn’t work on Mirror Screen
  • my MP4 + ASS subtitle works on Mirror Screen

Ok, since airplay is so unreliable with the subtitles I got myself a workaround solution.

I have a iPad Pro 2020 version using type C cable to connect the PicoPix as a screen then play my videos with infuse. In theory this will work on whatever video and sub format as long as infuse supports it

If you hv the lightening port devices, a lightening to HDMI converter should work too.

I am happy with this workaround as this will save me hours to try to figure out an Airplay solution (which may not even exist)

Hi,

I connected my Ipad 2020 with usb C to the PPM but I have a yellow screen saying no signal.
How did you manage to make it work ?

Could be the usb C cable that you use doesn’t transfer video signal. What cable are you using?
My iPad 2020 is simply plug and play

I used the apple cable. Yes you are probably right, will try the PPM ISB C cable.

You can use the Apple cable for PPM power and use the cable that comes with PPM to connect iPad Pro.