Subtitle styling not matching ATV 4K settings

We use subs a lot. On ATV 4K settings we have the subtitle style set for white text on a 50% black background. Works on Netflix and Amazon Prime.

On inFuse we see white text, but no background, and the text also appears larger, so not seemingly following the ATV settings.

Everything on latest versions.

With the same subtitle settings on an iPad, inFuse subtitles match perfectly the iPad control panel settings.

Any ideas on what I’m missing, or doing wrong, on the ATV?

Have you tried adjusting the subs on the ATV?

Yes I have. The ATV subs are set as white, normal size, with a 50% black highlite. The ATV settings sample screen shows what I see on Netlix and Prime, but inFuse shows no highlite backing color.

I meant have you tried adjusting the subs in Infuse on the atv.

I have Playback > Subtitles - On
Language > Subtitles - English (United Kingdom)

Cannot currently see any inFuse settings for subtitle font, color, size, background etc. Where would I find them?

Currently using 6.5.2 (3282)

While playing a video, swipe down to bring up the info tab and the go to the subtitle tab.

Select a subtitle.

Then there should be a bunch of options to control the display of the subtitle.

I don’t use subtitles very often so I don’t know if changed settings only apply to that specific video, or if it becomes the default for subsequent videos.


Just checked, and the full subtitle styling menu is there. Never saw that before, just the subtitle selection choice.

Thanks for your comment, got it looking just as we’d like it now.

Tried some different video files, the subtitle styling stays set.

1 Like

remotevisitor beat me back to the thread! LOL

Glad they got ya helped out. Enjoy!

1 Like

Thanks for your help. I hardly ever needed to look at the swipe down, maybe only if the default subs were not synced typically. Great to see there’s a delay available as well.

Here’s a follow up - I just loaded a MKV video file with embedded subs to our media server, started playing it on the ATV, and the subs were shown, but unlike other videos I’ve played, not formatted at all.

Looking at the swipe down it shows English subs selected, but there are no styling options shown. Went for … more and loaded an Opensubs SRT, closed the swipe down, re-opened it and the styling settings are there, and the subs are then displayed “as required”.

I’m sure this is why I was having styling problems before, seems some video files’ embedded subs are giving a problem.

Tried playing the same video on my iPad inFuse as well, and see exactly the same problem.

The most likely reason is because the embedded subtitles are “pre-rendered closed subtitles” which are encoded as images rather than text … in this case all the player can do is display the image.

1 Like

That makes sense, thanks for pointing out the embedded subs are sometimes images, I wasn’t aware of that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.