Subtitle persistence issue

I watch a lot of anime that has been fansubbed. Some of these fansub groups are using advanced overlays/masking of signs, posters, laptop or mobile phone screens. Infuse seems to sometimes have an issue of theses overlays/masks persisting. The only way it gets resolved is if another subtitle element occurs or if I exit out back to the season or home screen and then go back in to resume playing. It works the same way across macOS, iOS and tvOS (ver. 7.3.7, latest OS versions on all devices).

Example screenshots
Without subtitles:

Following scene without subtitles:

With subtitle overlay (signs & songs subtitle track):

Following scene after overlay with overlay persisting:

It feels like this used to work on older versions, but I don’t have an easy way to compare. Thoughts? I can upload example files if needed.

2 Likes

Can you try with 7.3.9 to see if the issue still persists?

If it does and you are able to upload a sample, it would be super-helpful.

Hi OP, have you tried extracting the subtitle and play the video with the extracted subtitle?
I encountered a separate subtitle issue with anime. Infuse somehow treats extracted subtitles differently and it worked as a workaround.

Finally have been able to try with 7.3.9…it exhibits the same behavior, so I’ll be uploading a sample.

I did try your suggestion, but I don’t seem to have an option in Infuse to pick the extracted subtitle. In advanced settings, the only option is to attempt to grab it from OpenSubtitles. Am I missing something obvious?

you need to manually extract the subtitle from the video using a software like ffmpeg. Then you can refer to the docs on how to use external subtitles with infuse.

I had extracted the subtitle but it wasn’t named correctly…so it couldn’t match up. After I figured that out, the external subtitle (with removed internal subtitles) works and ends when it is supposed to, but a new problem occurs as the overlay blinks rapidly while playing.

The subtitle issue I encountered also involved lingering lines:

Subtitle position pushed up when multiple lines are displayed in quick succession

but in my case, there wasn’t even any complicated overlays.