Subtitle memory clearing?

Just to be clear from the start here, I am talking about embedded PGS subtitles in an mkv file and not any other sort of subs.

I generally try to make sure that all my subtitle streams are correctly configured with forced flags etc. when I create my mkv files but when I first load a file into infuse I often flip between the different subtitle tracks to make sure they are labelled and setup correctly.

Then when I come back in I notice that it has remembered my prior subtitle setting and if this was an episode of a series it remembers those selections for every episode of the same series. So if I flipped to a Japanese subtitle on one file during import to test then every episode of that series will by default open with the same Japanese subtitle even if I have another forced and defaulted stream.

I can sort of understand the idea that you would want subtitle memory if you are watching episodes back to back in a session and you have selected a certain subtitle track.

My question is how do I wipe this memory and reset it back to the behavior as if I have changed nothing. I had got into the habit of just setting “None” on the movie/episode and expecting that it would then still apply the forced subs if I had “Forced only” set in settings but it seems like the last setting on a given file overrides all other settings which to me is a bit annoying and I would like to just “reset” the subtitle overrides or clear them so that it has no memory and start fresh based on the main settings and the flags in the subtitles.

Is there a way to clear this memory of subtitle tracks and just revert to doing what the main settings say?

For example, with current behavior, if I have a file that I open in Infuse and then I create a new version of the file with a forced tag on a subtitle it doesn’t select it, seemingly because it is remembering that it was previously run with “None”

Thanks

@James perhaps what I really want is that this “subtitle memory” by file/series/movie (not quite clear of the granularity) should be able to be turned off in settings. Currently I set up subs config in settings and then that gets overriden (seemingly forever) by a single change I make on a single file within a series. I don’t see this behaviour documented anywhere in the subs docs (although I could have missed it).

Most of the time I just want to open the file and it behave based on what the flags are set to not what I set it to last time (potentiallly months ago - not clear if this memory has an expiry).

I have tried deleting/removing the file and re-adding but it still seems to remember…

It seems that no matter what I do I cannot force Infuse to forget the last subtitles loaded. I have disabled iCloud synch, I have cleared all metadata and I have removed the files from my library.

I have then tried just loading the file using File->Open File… and yet Infuse still seems to somehow remember the last subtitle that was used from before I removed the files (!?), even if I then clear all metadata, re-scan and re-load metadata and then quit the app and reload.

For example. I loaded an episode of House that has a default and forced subtitle track that wasn’t being selected (because I had previously thought maybe I could clear the memory by selecting None - which doesn’t work). After removing all house episodes from my library, clearing all metadata from settings, re-scanning and then forcing a metadata reload, I then went and did a File->Open File and loaded the file from its location (that is not part of my library) and it still didnt default the subs correctly. It was still selecting “None”.

to prove this was due to the last setting I did the following:

  1. selected another Japanese subtitle track (that has no forced or default flags) from the file opened via File->Open File…
  2. Closed the video.
  3. Cleared all metadata from settings
  4. Did a scan for changes
  5. Did a refresh metadata

The last 2 things shouldn’t have made any difference as the file isnt even inside my library but I figured forcing a reload might remove old data…

  1. Then I quit Infuse and reloaded.
  2. I reloaded the same file via File->Open File… again and it was still defaulting to the Japanese subtitle track that has no defaulting or forcing from the previous selection.

Where on earth is the data that is keeping track of that last subtitle used for a file that isnt even in the library and after I have repeatedly cleared the metadata? :slight_smile:

Surely this is a bug? Do I need to delete Infuse to get it to forget a subtitle track that was chosen? I am running 7.7.4831.

I tried also disconnecting trakt (although I didnt think trakt would keep track of subtitle selections) but I can’t because then it loses the Pro subscription in beta.

Maybe I should try un-installing beta and switching back to the prod version and see if I see the same behavior. At least then I can also disable trakt as well…

Perhaps this is a niche ask but it is a bit annoying as it basically means that your subtitle settings dont really do anything as everything is based on what you have previously selected.

I was surprised that completely clearing all metadata and removing iCloud synch didnt resolve this.

Even removing Infuse beta and reinstalling the production release makes no difference. I disconnected trakt and made no difference. Any way I open the file it still selects the same Japanese subs that have no defaulting or forcing.

I tried creating a new copy of the file from makemkv and this time I changed both the name of the title and the filename of the file in order to try to stop it matching and using a local cached memory. This time when I played the new file via File->Open File… it didnt select the previously selected subtitle but instead it selected “None” despite there being an English subtitle stream that is clearly tagged as both default and forced and Infuse shows the “Forced, Default” labels in brackets.

Is anyone else having problems with how forced subs are working? I have also tried playing around with all of the other subtitle settings:

  • turning them on/off/forced only
  • changing the language from Auto to English and back

None of the changes made any difference when I loaded the same episode…I got “None” as the default… but once I select something else on that file I then get that selection forever with seemingly no ability to clear that setting.

As a final test I took another episode and labelled it so that Infuse would not think it was an episode of House. I called the title “DanTest - Season 1 - Episode 1” and the file “DanTest - s01e01.mkv”. When I loaded this into Infuse it had no idea it was a house episode and then when I played it the forced subs were automatically selected correctly. I also then turned subs off in the settings and played the file again and they were disabled correctly and then switched them back to “Forced Only” and the forced subs were correctly selected.

Definitely seems like there is something funny with the caching/memory of subtitle settings for a movie/series and it seems like there is no obvious way to clear them once you have manually selected a subtitle stream once.

I also tried going into iCloud settings in Mac OS and making sure all the Infuse data was deleted from iCloud. It made no difference. I have no idea where this information is being cached but it doesn’t seem to be cleared no matter what I do.

Infuse will carryover manually selected playback preferences set in an earlier TV episode to subsequent episodes in the same season. These choices will override the global options set in Infuse > Settings > Language.

This was added to avoid issues with having to reselect things like audio and subtitle tracks for each and every episode.

The logic is tied to files within the same seasons with the same file naming structure, as it is presumed the audio and subtitle track structures will be similar between these files.

There is no way to manually reset the choices for a particular season, but you can choose the preferred option when playing the next episode to override the previous choice. You can also rename the files to use a different naming structure as this should allow the season to fallback to using the default global settings.

Hi @james ok thanks for the clear answer.

Is there absolutely no way to clear this memory? It doesn’t seem to be cleared by metadata clearing or by iCloud data clearing or even by removing infuse and re-installing (deleting beta and installing public production version didn’t clear it).

It also seems to apply to a movie file as well? Is this correct? Once I select a specific subtitle in a movie that sticks as well going forwards?

Either having a way to clear this memory or to make it optional would be nice. Having this persist “forever” seems unintuitive and, to me, wrong. It makes it seem like the subtitle settings aren’t working because they are overridden on a file because one time you chose a different subtitle track.

Could this not be made to clear when metadata is cleared or something similar?