Subtitle Issues with Infuse 5.6

I’m running into issues with subtitles on Infuse 5.6 (issue also present in 5.5). It appears if there are slanted text in the current subtitle frame, white boxes fill the screen. Please see attached screenshot. This behaviour exists in Infuse 5.6 for both iOS and Apple TV. I am using iPad Pro 10.5 and Apple TV 4K.

Can you add this video file here e.g in the cloud?

Since I’m uploading a sample clip, I will go ahead and describe another issue I’m seeing. In MKVToolNix, I confirmed that the Japanese audio track and its associated subtitle track (Track 3) have the Default flag, however in Infuse, it always plays the English audio track and its associated subtitle track (Track 4) instead, neither of which has the Default flag. I have the language settings set to Auto in Infuse and in Apple TV.

To summarize, bugs exhibited in this clip:

  1. white boxes blocking the screen when there is a diagonal subtitle displaying alongside a normal subtitle (there are 2 subtitle tracks to prove this out, 1 with just the diagonal subtitle [Track 4] and 1 with both the diagonal and a normal subtitle underneath [Track 3])
  2. the audio and subtitle tracks with Default flag set are not being played by Infuse by default (the Japanese track and the problematic subtitle track [Track 3] are marked as Default but Infuse chooses to play the English track and the associated subtitle track [Track 4] without the white box artifacts instead)

You need to use the Forced flag. Infuse (and a lot of other players) chooses the subtitle for the language that you have set, so I set them to Forced and Default. For movies with non-English part subtitles I set those to Forced and Default, and turn off subtitles on Infuse to make sure only the subtitles I want played are played.

Thanks for the sample. We’ll take a look at this.

Both the Default and Forced flags are set. As a test I actually removed the Forced flag and it worked (the Default track is selected by default). It appears the Forced flag is telling Infuse to hide it.

Do you have Infuse set to show subtitles or not? Set it to not show subtitles, and the subtitle with the force flag will still show.

But I want subtitles to show in general. If both Default and Forced flags are set, Infuse should respect the setting and show it especially if I specify that I want subtitles to show. Regardless, the sample file is submitted, so I’ll just wait for the analysis.

I see a similar issue with PGS subtitles. When there subtitles at the top (or middle) of the screen and at the bottom of the screen, the area between them are filled with black boxes. Same issue with Infuse 5.6 on iOS and tvOS.

Thanks for the note. We’re looking into this issue and hope to have a fix soon.

Update: This issue has been fixed for the upcoming 5.6.2 version. :slight_smile:

1 Like

Thanks! Does it include the wonky Defaults flag handling behavior or should I file a separate thread for that?

The changes in 5.6.2 will be for the white/black boxes appearing with PGS subtitles (as well as some other subtitle display related items).

With regard to default flag, what language is selected in Infuse > Settings > Subtitle? By default this is set to Auto, and Infuse will attempt to display subtitles in languages that match the setting of your Apple TV.

I have audio and subtitle set to Auto, and my Apple TV is in English. However the Japanese audio track has the Default flag set and comes before the English audio track, and the Japanese subtitle track has both the Default and Forced flags set where the English subtitle track has neither. VLC and other video players I’ve tried either 1) respect the Default flag regardless of the OS language, or 2) go in order of track number instead of autoselecting the OS language tracks. The prioritisation of the OS language tracks is a bit inconvenient for people who own a collection of foreign videos (that happen to also supply dubbed tracks) but prefer to use the OS in English.

Actually, the settings in Infuse let you customize what languages Infuse uses in different parts of the app.

By default, having Subtitles set to Auto will cause Infuse to prefer English tracks, since that is what your Apple TV is set to. If you want it to prefer Japanese subtitle tracks, then change it to Japanese. The UI will remain set to English, but Japanese subtitles will be displayed - if present.

The same thing can be used for metadata and audio tracks, if you want those to be set differently than the main Apple TV setting.

Awesome! This combined with the auto switching of frame rate and dynamic range will take Infuse to yet another level. Next up should be optional list view for selected folders :slight_smile:

That solution only works for 1) libraries with only one other foreign language, as you cannot set multiple language preferences in Infuse, and 2) audio tracks, because for subtitles that are a translation of the foreign language, they’re marked as English and as a result the Infuse setting does not affect it.

I can better describe by example:

Audio tracks:
Track 1, Japanese, Default flag
Track 2, English, no flags

Subtitle tracks:
Track A, English translation of Japanese audio, Default and Forced flags
Track B, English subtitles of English audio, no flags

Apple TV: English
Infuse settings: All Auto

Infuse out of the box decides to play Audio Track 2 with Subtitle Track B (neither of which has the Default flag), when every other player I’ve tried plays Audio Track 1 with Subtitle Track A. If I were to set Infuse to prefer Japanese audio, it will then play Audio Track 1 with Subtitle Track B, which is the subtitle track for the English Audio Track 2, causing mismatch. And since both subtitle tracks are in English, setting Infuse to prefer English/Japanese subtitles does nothing to affect the outcome. Setting Infuse to not display any subtitles at all does allow Subtitle Track A to force itself via the Forced flag, however I want subtitles to display in general for all videos, including ones that only have one English audio and one English subtitle track.

This isn’t blocking media consumption like the subtitle artifacts did, so I can certainly work around it by manually setting audio and subtitle on every foreign video I watch, but it is a very inconvenient behavior that would drive me to an alternative as soon as a viable competitor for the Apple TV comes out (I already use something else on iOS).

I get where you’re coming from. Infuse currently does honor the default flag for audio tracks, and honoring it for subtitles as well is probably a good idea, and something we will be looking into adding.

FWIW, the forced flag has a different use, so I wouldn’t recommend using that unless the subtitles are in fact forced (forced meaning they are displayed only in certain parts of a film - EG when alien languages are being spoken).

I’m actually not sure if Infuse does actually honor the Default flag on audio tracks - when I tried the sample clip I uploaded for the subtitle boxes issue, the Japanese audio has the Default flag and Infuse still decides to play the English audio by default. To be fair I tried it with 5.6.0, so if that was added later on, that’s great news.

I totally understand that the Forced flag is meant for the case that you describe; Handbrake chooses to add it to subtitle tracks that the user marks as Default because some players (IMO erroneously) use that instead of the Default flag for their default track selection. I do want to make a clarification on the subtitle Default behavior however, again with an example:

Case 1:
Track A, Default and Forced flags
Track B, no flags
Infuse subtitle preference: Auto
Infuse picks Track B by default

Case 2:
Track A, Default flag only, no Forced flag
Track B, no flags
Infuse subtitle preference: Auto
Infuse picks Track A by default

Case 3:
Track A, Default and Forced flags
Track B, no flags
Infuse subtitle preference: No subtitles
Infuse picks Track A by default

Infuse does respect the Default flag as long as the Forced flag is not also present, otherwise the Forced track is only ever selected if Infuse is set to not show any subtitles by default. This may be a bug with the order in which the Default and Forced flags are processed, where if Infuse is set to show subtitles, Forced tracks are ignored altogether in the default track selection process. Because both tracks are English (in the sample file where you can observe this issue), I don’t think this relates to language settings and is purely with the selection logic. For now I can try to run a batch script to remove all the Forced flags from my files, but the Forced flag affecting default selection is still very strange.

I’ll have to double-check and see if we are looking for the default flags on audio tracks. I recall we had looked at it some point in the past, but now I don’t remember if it was actually implemented.

Also, thanks for the detailed info. We’ll be sure to look into the inconsistencies with default/forced and get those addressed, if needed.