Subtitle frame pause for AppleTV infuse 7

wondering if anyone is seeing a similar issue with subtitles on AppleTv.
I am running an appletv 21 with latest infuse pro 7, apple/TV is set to 4K dolby vision 50hz and Match content set to Range and Frame rate, and with any subtitled file (external subtitles in the folder, or embedded in the file) there seems to a frame pause before almost every subtitle appearing on the screen.
So the subtitle is about to appear and 1 frame pauses for an instant before the subtitle shows on screen. it almost looks like a frame skip or drop, but i filmed it in slow motion and noticed a pause right before each subtitle is displayed.

I have tried with background, no background, fonts and colour changes but there is no difference.

anyone with similar issues or fixes or help would be ace.

Can you show the video you made? I believe I have the same problem.

1 Like

I noticed the same thing. I’m pretty sure it started a couple of days ago for me. It started the same time as the issue with audio not playing until I rewind or fast forward on a video. The audio issue has been reported on another thread.

1 Like

You can notice it more on the second of the subs.

Should also mention that i tested MrMC on AppleTV with same settings with the same file, and the subtitle doesn’t skip, so im guessing its infuse related, not settings.

1 Like

To help us troubleshoot this further, can you replicate the issue and send in a report from your device?

1 Like

Hi James, just done.
do you need me to PM the keyword?

You can post the 5 digit code here or PM it. Most just post the code. :wink:

1 Like

Hey Seth, i checked your video, is it the same pausing issue you see at your end?
On your video the subtitle appears quite smoothly, but im not sure what im looking for.

you will see a pause on the 2nd car when the subtitle appears (sorry if the English is bad)
watch in slow motion

What is it that sounds like a camera clicking at that same exact time?

watch in slow motion, at the time of the appearance of the subtitle, the car pauses

I see the pause, I was just curious as to what was causing the noise that sounds like a camera shutter clicking at that same time.

I’ve been explaining the problem for years, present on all video formats, all apple tv, all subtitle formats, srt / pgs / etc. I had explained that the problem was present only on the 1st, and following them no problem, and if we move back the video the problem has disappeared (sorry for the English)

Never mind. Not important. :wink:


I have made another video, its quite visible here with the pausing as the sub starts

Today’s 7.2.1 update has a number of playback and subtitle rendering related improvements.

Please try installing this update and let us know if you see any further issues.

I reproduced the same problem

I tried 4 times on the same film to succeed in reproducing the problem,

Hi James,

Ive tried again, but it still seems the pausing is persisting.
so ill try a few different TVs with the same file and see if its visible.

on an ipad, using infuse, subs are perfect

I tried on 5 films, I could not reproduce the problem, then I restarted a film several times and the problem appeared, it is very random.
the problem is unbearable, it’s the only problem I know with infused

Can you try changing the ‘Streaming Cache’ option in Infuse > Settings from ‘Auto’ to ‘Legacy’?

We’ve seem some Apple TV devices which suffer from lower disk I/O, so it’s possible this may be contributing to what is going on here.