Subtitle downloads error


I’m using apple TV 4k and since a few days ago I’m unable to download any subtitles. Always goes straight to check your connection error.
I thought it was a downtime or something on the opensub api but now i see the status is green and has been past week.
Tried restarting the AppleTV, dumping the communication apple tv does with the api but as it’s TLS it told me absolutely zero information…
I feel like the API is rejecting me straight away, but when I go to I get a normal response…

Can I debug this in any other way? As Infuse plays only from network, I can’t test this behaviour with a different connection.

What geo are you in? In some cases infuse uses proxies to get around local requirements and maybe those aren’t working right.

I’m in czech republic.
In the tcpdump infuse connects straight to opensubtitles api IP so there shouldn’t be any proxy.

Do you have the same problem with a phone/iPad?

Yes, same error on all platforms. I found a way to use VPN to my local network which means the subtitles were downloading through mobile network and it worked.
I will try to debug my home connection more, but without the responses from opensubtitles API I’m kinda in the dark. It almost seems like my public IP is banned or something…

Hi, i have a similar problem about a week or so ago, never had any problems before but now I get an connection error, I see the subtitle files but get an error while downloading.
I must say that I use an vpn client in my Asus router but not connecting to an other country than where I live. (The Netherlands) and it worked before…
When I stop the vpn client in the router the error is gone and all is good.
I’ve tried to switch another DNS server(s) in the router but that is also not working, I even can download the subtitles on my iPad while the VPN is activated… so what is going on?

Thanks. I’m seeing exactly the same behaviour. I see the list of subtitles but I can’t download.
I’m not using any VPN but I’ve a suspicion that the opensubtitles API somehow blocks requests from my IP.
I will try to contact opensubtitles support

Oké thanks, hope that it will be solved…

Update! I have just changed my VPN profile with a new one and at this moment it works again… not changed the DNS servers within the router but I did a new registration of the DDNS service from ASUS, hope that this can help you… regards

Yep I’ve just received a reply from opensubtitles that they did block my IP.
They said I should google my ip that there is a lot of trouble, but I can’t seem to find any on any blacklist or reputation check.
They delisted it but said in the future it could end up blacklisted again.

If this problem comes up again i’m going to have to setup a VPN and route all requests to opensubtitles API through that :frowning:

BTW they have some sort of automatic blacklisting of IPs that are a part of known VPN sites or have a bad rep. So that might be also on your end.

Shure, I’ll keep that in mind…