Subtitle download menu is really impossible to use

For example:

Arrow S04E10, I have to scroll through a list of a few hundreds subtitles, and I am still unable to find the correct one. It shows the episodes of every Arrow episode ever added, including subtitles of something else then this show.

Dark Net S01E01, I find episodes of every TV show ever made, but NOT Dark Net, I see subs like Smallville, Buffy, Friends and more, this one is really impossible.

And for every other TV show I find subs for every episode ever made for these shows. Sorted on downloads.
At first sort these on SxxExx and then the number of downloads (popularity).

My guess is that there is no subtitle file for S04E10, so opensubtitles.org shows you all available for that series.
When there are files for that specific episode they come up first.

That’s not completely right. Even shows which have subs, I have to scroll al the way down because it has like 40 downloads, but still all subs visible. There is no filtering on SxxExx as it seems. And sorting on downlods.

Think its a bugg releated to autoplay. When i play an episode the subtitels works just fine. But as soon as the autoplay starts the next episode i get the problem you describe.

For me it is not working properly for specific shows at all. Not related to autoplay.

We’re looking into this a bit, but can’t seem to replicate the issue when using auto-play, or just playing an episode straight away.

In both cases, Infuse always seems to correctly use the season/episode to search.

Can you provide a few exact filenames you are using, and the subtitle language you are searching for?

Hi James,

Thank you for you’re reply. First of all, I search for ‘English’, because new episodes don’t have subtitles in my foreign language yet. (Reported earlier the ability to select 2 languages to search for, foreign language as wanted, English as fallback.

About the filenames and some more researching:

For Arrow:

Arrow.S04E10.HDTV-720p.DIMENSION.mkv
What I see when I open subtitles:
https://dl.dropboxusercontent.com/u/7528392/Bugs/Arrow.jpg
All subtitles with the name ‘arrow’ in it, for all episodes, and another TV show visible.

This is going fine for Arrow S04E11: Arrow.S04E11.HDTV-720p.DIMENSION.mkv, shows what it should be.



Dark.Net.S01E01.HDTV-720p.CURIOSITY.mkv
What I see when I open subtitles:
https://dl.dropboxusercontent.com/u/7528392/Bugs/DarkNet.jpg
This one shows hundreds of subtitles for like every show that exist.

More strangely, episode 2 of Dark Net is names:
Dark.Net.S01E02.HDTV-720p.CURIOSITY.mkv
But shows as expected that there is nothing available.
The filename is almost the same as episode 1.



If I look at S01E03 of Colony, named:
Colony.S01E03.HDTV-720p.KILLERS.mkv
This is just showing what I expected, only subtitles for this episode.

I’m having the same problem with the subtitle list not filtering on the season and episode number. It used to work. Doesn’t work all the time since 4.02.

I’m having this issue with the latest shows I’ve added of Big Bang Theory, Greys Anatomy and How to get away with murder. In all cases the latest episodes, expect for How to get away with murder. The entire second season we can’t resolve proper subtitles.

We use English subtitles, so the availability should not be the problem.

Happens too much. Have to download the sub on my phone and SFTP it to my server.

Is it possible to have Infuse look at a local folder for downloaded subtitles??
I have a folder but Infuse doesn.t look at it and tries searching online instead

Infuse does search for subtitle files in the same folder as the video file.

ahh… i have always put subs in a different folder and pointed my software to look at it
thanks

The Same happens to me, All my files are properly named like this Title.of.Serie.S01E01
i get correct subtitle matching 6 out of 10 times. 4 out of 10 times all episodes from every season matches. This happens with each series I tried.
A manual search field would be greatly appreciated if the bug is hard to reproduce.
The experience of Infuse is really top notch except for this.

So I’ve had this problem since the last update.

Today this problem got completely solved from what I can tell. We’ve seen four episodes of different tv shows tonight and all showed the correct subtitle at the top of the list.

What solved it for me was that I got a code to redeem the Infuse Pro version from the App Store to replace the Free Infuse version I was running out of which I upgraded to Pro.

By deleting the free Infuse and installing the Pro version the subtitle matching got resolved.

valderrama: Sounds promising. Will try the new update when I get home. I’m already a Pro user since start though.

Are you saying that you had the Free version with the in-app purchase to Pro, and it behaved differently to the version which has the Pro baked in without an in-app purchase? If so that is rather strange as both routes are meant to lead to the same capabilities. I wonder if it was the deleting and re-installing that really did the trick or if there is some subtle difference between the two ways of getting to pro?

I have both. Pro version with code redeem, and the free version with in-app purchase. I am experiencing this issue in the latest beta version.

Yes, I had the free version with the in app purchase to Pro. It used to work fine but somewhere along the way it broke, most possibly after updating to the latest version.

It got fixed after deleting the free app and installing the stand alone Pro version. I can’t tell if that was specifically the solution and that the two apps behave differently or that it got fixed by simply deleting the app and installing it again after which you need to configure it again making it gather all the metadata etc…

Can you try removing and re-installing the app (both versions)?

We haven’t had any luck replicating this issue here.

I have this issue too, I posted all subtitle releated issues in a new post, which hopefully will be fixed very soon.

The long list does contain the right subtitle (in most cases). I guess there is a search algorythm issue. But for a $10 app that should be fixed.