Subscription issues - Network Error

I’ve been using Infuse for years, but recently been having issues with my account. In the last few weeks its almost like my account is no longer active on Firecore’s end, when Apple says that it is.

I’ve tried all of the suggested steps with no success. I deleted the app, signed out of my App Store account, rebooted the phone, signed back in and re-downloaded. Still says my subscription is active but unable to sign in. AppleTV gives the same errors, same with iPad. When I click “restore” it beach balls for a minute then does nothing. When I click subscribe it says “You’re already subscribed to this”. I click ok and it says “Network Error - Check your internet connection”, but my connection is working fine otherwise and I get the same message on cellular. It’s like it can’t connect to the Firecore server to authenticate the subscription. At this point I’m not sure there’s anything else on my end that I can try. Anyone have any other ideas?

Not knowing what you mean by

I’ll just reference this in case it’s different.

Thanks for the response.

What I mean is I have tried all of those steps. Here’s a quick video of an attempt to sign in from a new install, right after rebooting and signing back in to the App Store. It all ends in Network Error. Happens every time, from any device, on any internet connection.

Just curious, what if you delete the app, then re-download it. Launch it then instead of trying to restore or subscribe, when you get to the add files screen instead, click on the gear and go to the library. See what the messages say on the library screen and if it is trying to sync to icloud.

It recognizes that I have some folders but doesn’t index anything. But I’m also not currently at my home where the NAS is located. I assume if I were home it would index properly. When I was home on the weekend I could see the files, and play supported files, but can’t use any of the pro features because I can’t access my subscription.

It should go through an iCloud sync first when it’s the first start on a new install so it would get the prefs from iCloud. That is where mine would see it was an active subscription before it would start the sync. Did you delete the app and reinstall it without trying to restore it or clicking on subscribe and just go straight to the library and watch the messages?

Yes I deleted and installed fresh, then went straight to the Library pane as you had suggested. It syncs the folders from iCloud just fine. But it doesnt seem to ask or check for any subscription, just immediately starts syncing with iCloud when I open the library.

Sometimes the App Store is weird.

Can you try this.

  1. Sign out of the App Store
  2. Restart your device
  3. Open Infuse and attempt to restore your purchase (you should be prompted to sign into the App Store)

I just tried it. It did prompt for Apple ID when I hit the button, but it gave the head shake like I didnt have a subscription to restore. Although clicking pro at the top says I already have a subscription.

I fixed it using a different approach. In the subscription options there are two choices for each plan for some reason. I selected the other yearly option and subscribed to it. When I relaunched I was able to restore and my other device instantly recognized it.

So maybe I just bought it over again. Either way its working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.