Subs in Denmark

So I’m getting a message that I can’t get subs from opensubtitles… claims it’s my internet connection. Pretty sure it’s not though.

Any ideas?

Thanks

Status page (bottom left of forum pages) shows that opensubtitles service is having problems.

Thanks!

Didn’t know it showed there. Will keep an eye on it. :slight_smile:

That’s for the (Legacy) version API.

If you’re using the current version of Infuse it’s using the (New) and that one is not showing issues.

To the OP, what country are you in and can you go to www.opensubtitles.com in your web browser?

Ah… yeah I’m in Denmark and can’t access the opensubtitles.org page…

What then? :confused:

Probably best to wait for James to chime in on this one. There was a similar issue with thetvdb and Firecore figured out a way to restore the functionality for that service.

While digging around in the dusty archives here I found this that may help subtitles still doesn't work :wink:

Yeah I’m already using that DNS solution. Still doesn’t work though. :confused:

Are you using Infuse 6, or an older version?

Can you try force-closing the app (or restarting your device) to see if that makes a difference.

If the issue persists, please drop us a quick note from your device so we can look into this.

Restart didn’t help. Tried both dns’es. 8.8.8.8 and 8.8.4.4

Didn’t help.

Using pro version 6.2.3 (2848)

Sending in message from the app after this

Thanks

It happens to me too and I’m Danish as well. I’ve been using 1.1.1.1 as DNS for a long time, and it’s been working great. Suddenly it’s stopped. Oh, and I can still access the website…

Did you try the suggestion that James made above? If so, you may want to send a diagnostic report and post the code here.

Frist thing I tried - still not working. I’ve submitted diagnostics: 3GK9V

Thanks!

I’m sure James will dig into it when he can. It’s strange that you can still access opensubtitles.org on a web browser since the op can’t. I wonder if it may be a internet DNS problem in the country? Maybe an update to their DNS lists got hosed.

Interesting. I found this redirect when going to api.opensubtitles.org and dl.opensubtitles.org, which is a some legal notification about blocking domains in Denmark - this is probably it. Have to find a workaround… https://rettighedsalliancen.dk/wp-content/uploads/2018/03/Frederiksberg-District-Court-RA-v-TDC-5-December-2017-Popcorn-Time-EN.pdf

That’s the same redirect I’m getting.

Got same problem, started this week?

Are you also located in Denmark?

Yes, but never had this problem before. Have been running Infuse for 2 years now

So some digging by others has revealed that not even DNS over HTTPS (DoH) will fix this redirect. It seems that the only current solution is using a VPN.

Personally, I would like to hear what you guys at Firecore (@james) are thinking, as this seems to be a clear disimprovement of your product, if subtitles no longer can be fetched in some countries. Some sort of build-in VPN or proxy for opensubtitles might be a solution.

Anyway, hope to hear from you.