Stuttering video after update to 4.1.5

After updating to 4.1.5 most of my video TS files play with an annoying stuttering. Before the update all could be viewed perfectly (4.1.3). I have the latest version of Apple TV OS, run Smart-Installer several times and checked all settings. However without any result. I stream the video’s from a nas (cabled). My last effort could be to run a complete new set-up. Perhaps anyone has a suggestion?

I have the same problem. Also faced the same issue with 4.14, the only solution then, was to factory install my atv and do a fresh install. This time not even that is working

Infuriating!

@saundg or @lhom

Are you guys running external hard drives? I will assume you are, otherwise there isn’t a lot space for VIDEO_TS folders.

Are you using USB powered drives (i.e. portable drives w/o separate power) or larger external drives with their own wall-wart?

Thanks,

Ken

How often would you say the stuttering is occurring? Is this with all DVD files or just a few?

This isn’t within any DVD files. This has all been within *.M4V files sync’d from iTunes; most of them purchased videos from the iTunes Store.

Are these stored on the internal or an external drive?

External HDD.

– Ken

The problem I have is with all my DVD files that are ripped into vob/ts folder. Smaller mp4, avi files play fine.

My setup is Ethernet connection to a machine, with the files on attached external drives with separate power.

The stuttering is very bad and makes the DVD,s unwatchable, it also seems to effect the DVD menu operation to a lessor extent.

As I said before, all of these DVD,s played perfectly before the upgrade to 4.15, and I had the same issue after upgrading to 4.14, however that time I resolved by a factory install of atv, plus a clean installation. This time, even that has failed

In my case the video files play with a stutter or a rare freeze. I rip DVD with RipIt (_TS) and I use Handbrake for mp4. These and some .mov files are played with NitoTV and always play with a stutter/freeze which appear every 5 to 10 minutes.

My set-up consists of a NAS Synology with 2TB HD. All is cabled with cat5 and only video files are streamed from the device. Music and photo-libraries are synced with iTunes.

I checked all settings in the AppleTV and NAS and re-installed Smart-Installer several times (shows the date of the last update). I have no clue what to check next. Last thing is try is a fresh install and see if the stutter dissapears. If not the case, I think about a downgrade back to 4.1.3 wherein all ran flawless. But then the issue of the missing audio (intro video) is back :cry: . What’s then the point of an update if you start to fear them?

I will be interested to hear how you get on with a clean install. I wasted days after updating to 4.14 before resorting to a factory reset, that worked, but after updating to 4.15, even a clean install has failed.

I am at a complete loss as to what next, and have not received any response from support. I agree that it is pointless to release upgrades that have users dreading the outcome, especially with no support on hand

I’ve had this problem all along and have just learned to “live with it.” For me the stuttering happens in the first 10 minutes of watching, maybe 1 or 2 events every 30 seconds or so, then it settles down to a smooth video… unless I hit “pause.” Then I have to put up with another few minutes of stutter once it’s restarted.

I’m certain this has something to do with external drives. I have 2, 1TB (powered) drives running through a USB hub (also powered). I rip my DVDs and process them as m4v with Handbrake and place them on these drives and play them through the “Media” menu on aTV Flash. Most (not all, but most) of the time I will get the stutter as described.

Here’s why I’m sure it an external drive thing: I record TV shows with eyeTV. eyeTV automatically converts these recordings to m4v and places them in my iTunes library. iTunes then syncs these files to the Apple TV and puts them in the units internal HD. I play them from the My TV menu and they all play flawlessly.

It’s a pain, but the convenience of being able to store and watch my entire collection from drives (as opposed to hundreds of DVDs scattered around the house) is worth the hassle to me.

I think you may have a different problem, the stuttering Is not for the few minutes and it is not occasional. It is consistent and makes the DVD,s unwatchable. In addition it only happens after an upgrade, before the same DVD,s played perfectly

I’m quite positive nothing regarding network streaming was changed in the new version, though I will try and confirm.

Personally in the past I’ve seen some stuttering like this which was caused by a damaged or failing USB cable. Simply swapping the USB cable for the drive in question seemed to resolve the issue.

Max
I,m sorry but that is not the issue. I have tried different hard drives, and cables, and the results are the same. All vob/ts suffer from horrendous stuttering and the DVD menus behave strangely. Other video files play fine.

As I have explained, ALL of the effective files were playing fine before upgrading to 4.15 and I suffered the same experience when upgrading to 4.14, although I resolved that with a clean install follow a factory reinstall of ATV.

It must be something to do with either the upgrade, or something happening during the upgrade process.

Any ideas please?

Hi. Anyone had any luck with this yet? I spent an hour on iChat to support, but still the same problem.
Have tried another factory reinstall and clean 4.15 install, but no joy

Today I took time to do a factory-reset of the AppleTV and performed a fresh install of ATV Flash 4.1.5.
I checked all instructions (Smart-Installer etc) and finally reconnected to the (cabled) network drive for streaming video (mostly video_TS and H.264 files). However, and despite the re-install, the problem did not disappear. While streaming from the NAS, NitoTV remained playing with unbearable stutter and freezes.

To determine whether this was caused by NitoTV OR the network drive (perhaps a wrong setting?) I installed XBMC which connected with the exact same network-setting as NitoTV. To my surprise XBMC performed extremely well. The indexing and navigation in XBMC went very smooth, all tested video files streamed without any problem.

Finally I attached a USB drive and played the same files again in NitoTV. Again to my surprise, NitoTV showed no problems in playing the files. The indexing went quickly, navigation went smooth, and all videos played perfect.

I can only conclude there is a bug in NitoTV that affects the streaming from a network-drive. It causes the stutter and freezes because the connection is unstable. Moreover, this only affects NitoTV and not XBMC.

I would appreciate if someone at FireCore have a look at this. It did not occur in the previous versions, it has to do with the update 4.1.5. If not the case please inform me what might cause this problem. Though I can watch again from an usb drive I prefer the use of my (noiseless!) network drive.
Thanks in advance.

We are looking into a few similarly reported issues. Sorry for the trouble.

I did an update from 4.0.5 to 4.1.5 over the weekend and now I do have the following problems:

  • nitoTV stutters with every file I tried, no matter what file type
  • sometimes it comes to a freeze and I have even to restart the AppleTV

What I noted is: Whenever I select a file to watch via nitoTV for a brief moment I can see the actual finder-window popping up and a the cursor wheel spinning. Then the movie tries to start but often fails.

The files I’m trying to watch are 720p .mkv files which are stored locally on my AppleTV harddrive. The exact same files played without any problems under version 4.0.5.

Files synced via iTunes and played under the MyMovies sections from the AppleTV are not affected.

Restoring the whole AppleTV (factory reset) and re-installing aTV Flash did not solve the problem.

You may try the following.

  1. Switch ‘file playback mode’ to Quicktime through nitoTV --> Settings --> General.
  2. Disabled ‘Apple H.264’ through the Maintenance --> Settings menu.

When first playing the file, hit pause and let the blue bar (buffer) fill up.

See if the file playback improves.

Has anyone tried reverting to an earlier version to see if the stuttering goes away?