Stuttering playback after tvOS 15.0 update

Could you explain this just to make sure I understand? Do you mean you set the “Streaming Cache” to “Legacy” in the Infuse settings under “Playback” ?


Yes, “Legacy” (not “Auto”).
Read speed test:
“Legacy” = several minor changes from the average (100% → 80-90% )
“Auto” = less but “huge” change (100% → 50-60% )
It is possible that this is also just a coincidence.

Could be but with another user restarting their router and seeing a change that may be a couple of clues pointing to a change in OS15s handling of networking that may be an unforeseen issue.

Just looking for similarities. :wink:

Hey :wink:

I have not noticed any Stuttering…
But I must say, I have set the StreamingCache to „Legacy“… Maybe „Auto“ is really the Problem

I was hoping but tonight I changed to legacy from Auto and for 2 videos it was fine then back to the stutter. Still could be a networking issue with error correction or protocol. I’m sure Firecore will suss this out.

Can confirm, after multiple days after a full reset, it’s been working perfectly. Have not had any issues with playback at all. Only issue is the minor delay with spatial audio when streaming a show from Apple TV, which is going to be on Apple to fix, but other than that, playback with Infuse has been solid.

I recommend someone else giving It a try.

This issue is related to changes in iOS/tvOS 15 and is not related to network cache or speed. It should be resolved in the upcoming 7.2.1 version.


Hallelujah! This was driving me batty …

Thanks James! Any ETA of it?

We’re submitting 7.2.1 to Apple today, so it should be out within the next few days.


Same problem here. I have stuck playing video with mp4 files it seems ok with mkv files with inside a mpeg 2. Before update to iOS 15 all was ok.

What is happening? Some more detail of what’s happening and a screen cap may help. What version of Infuse and you say iOS 15 so you are on an iphone or ipad?

Sorry, tvOS (I have a first gen. Apple TV 4K). It is happen that the play is not smooth it is jerky.

I am also having the same issue with the choppy video. To correct this, I need to FF or RW and it seems to solve the issue. I have the first gen ATV4K and Infuse Pro 7

This has been resolved in today’s 7.2.1 update.

Thanks for your patience. :slight_smile:


Hello, I have done the update, it doesn t solve anything on my side, it stutters all the time with the apple tv 4k. Same content is read flawlessly on my ipad pro.

Can you double-check to ensure you’re running 7.2.1 (scroll to the bottom of Infuse > Settings).

Yes it is.

Does this affect all videos or just a few?

Do you have the Match Content options enabled?

Can you send in a report from your device so we can investigate this further?

Seems to work much better on other films I have tested, so it seems to happen on just a few.
I have match content enabled.
Will send the infos.

1 Like