Stuttering playback after tvOS 15.0 update

Anybody try 15.1?

I’m also getting buffering/not playing at all on videos that used to play with no issues since updating to 15.0. This is all on direct play too. No issues if I play on Plex though.

The 7.2 update seems to have improved the situation. I think I’m seeing some real improvement.

MOD EDIT: Changed the version from 7.3 to 7.2 in this post by @oferlaor since that’s a typo and to help keep the confusion factor down. :wink:

For me the problem is still here.

I will continue monitoring, I’m extremely sensitive to missed frames and stuttering.

Thank you guys for replying, appreciate that, I’ll try give as much detail as I can, with that said I haven’t had a chance to test 7.2 yet so I may report back later.

There are two issues as far as I can tell.

Framerate Matching: The function works well by itself but 9 times out of 10 playback is going stutter town one way or another, it doesn’t matter if it started off smoothly or not, it gonna end up stuttering. This happens to all file formats, H264 and H265, Audio codec doesn’t seem to play a part here but I could be wrong.

Dynamic Range Matching: Sometimes Infuse failed to switch dynamic rage too, so when I play a HDR movie it uses SDR mode, which is easily verfiable because my Sony set uses max brightness for anything HDR.

I would like to point out that Netflix app suffers from these issues too more or less, playback back is fine but frame rate matching just doesn’t work at all, dynamic range matching acts up from time to time.

I hooked up my Apple TV box directly to my Sony TV, using Jellyfin as backend running on a Synology NAS, everything is connected by ethernet cable(CAT 6A) & HDMI 2.1 cable so connection quality & speed are the last things I would suspect.


7.2 does have some fixes in place that may help so give that a try when you can.

I think Apple has some bugs to squash but it’s going to make it tough for the devs to not fix it now to have the next apple update break it when they change things. That’s one reason I’m glad I don’t do that kind of work to put food on the table. :wink:

I agree, network shouldn’t be an issue so let see what 7.2 does and maybe 15.1 will be close too.

I don’t do a lot of HDR or different frame rates so I haven’t noticed much of an issue so keep us posted.

Sadly the issue stuttering playback is still happening, less frequent tho, but still there.

Tested on a 1080p remux.

Yeah, I was playing back a TV episode last night where it went full-on stutter right from the start. Stopped and restarted playback, still the same problem. Stopped and restarted again but this time choosing to start from the top, no stutter.

It’s not necessarily a tvOS 15 thing by the way. I’ve run into the stutter thing multiple times before, using after skipping to a new chapter in a file. In those cases, usually skipping back to the chapter start again fixed it.

sorry, I meant 7.2, thanks Mod for fixing.

1 Like

Loos like they are looking at this next 7.2.1

We have a beta available today with a number of improvements in this area.

If anyone would like to give this a try, please drop me a PM and I can add you to TestFlight.

Something interesting from yesterday. I had a situation with severe stuttering. A 50fps 1080p file playing in tvOS 15 with set to 50hz and adapt rate+range both on and English subtitles forced on. Stuttering was every few seconds and then stopped and then repeated again.

I tried playing something else. Ultimately, restarted appletv and issue was gone. FYI.

I’ve been having this issue as well, but may have resolved it, at least it seems to be working properly again. I did a full factory reset on the AppleTV. I selected Reset and Update so it would be a fresh install of tvOS 15. So far it’s been playing videos properly even if I pause, fast forward, rewind. Not experiencing the stuttering I was before. Will keep you all updated it if happens to come back at all.

After a complete shutdown (no power), the problem is resolved.
Maybe not just temporarily.

( Apple Tv 4K + TVOS 15 + Infuse 6.7 )

1 Like

I power cycled my 2017 ATV and two shows that I was having issues with are now playing properly. I did have stuttering playback once after pausing one video, but stopping and restarting the video fixed it.

Yesterday this problem come back strongly :grimacing:
A 1080p file got stuttering playback in a severe way. Fast forwarding / rewinding didn’t solved it like before. Only exiting the file and entering again solved it.
That’s really not ideal like I said before. I’m afraid to stop or rewind something, afraid of it starting to stutter.

Sometimes it’s bad again.
The latest antidote:
streaming cache
older version
(instead of automatic)
Apple TV 4K + TVOS 15 + Infuse 6.7 & 7.2

Every time I click on (resume playing) after watching a movie or TV show, it starts to have a stutter or choppy playback. I either have to exit out infuse and open it again, or rewind like 5 mins and then hit play or I have to restart my router???. So hopefully we can get this problem resolved because I have been using infuse for 2 years and it has worked flawlessly, So it is challenging to put up with stuttering after such a perfect record lol. Thanks for everything you guys do, my movie collection has come to life thanks to you guys.

After 3 days of having it being reset , has your problem been resolved? Are you noticing any choppy playback?