Stuttering playback after tvOS 15.0 update

Hello, I’ve been getting stuttering playback like a lag/buffer problem every time I stop and hit play again, or fast forward rewind a video.
This never happened before, started happening just after the tvOS 15.0 update.
I don’t know if that matters, but I’m using Plex media server as my library source.

3 Likes

I get similar here too. Looks like by restarting the movie solves my problem. Hope this will be recitified in next build of the Infuse app.

Solving the problem momentarily is easy.
Like you said restarting it works, or fast forward / rewind / pause a couple of times solve it too. However, that’s not close to a solution as I use these functions a lot in some cases and it’s annoying in a way that’s close as “I better try to just watch it with 110% of attention than pause or rewind it”.

I am having the issue too. I thought its my tv’s motion setting playing up but then realised that it only happens in infuse and not in the other apps. Hope this can be fixed soon.

This might be the same issue I’m having - it looks like it’s dropping frames.

Same here

@james any feedback into this?

I am also having this issue since updating to tvOS15. Things are smooth for 10 minutes+ and then things get jerky and need to try and pause\play video or restart the app.

Can we please get this fixed soon. Infuse is basically unusable now.

I may as well cancel my monthly sub until it’s fixed.

Upgraded to tvOS 15. Had stuttering that looked like half frame rate. It happened after fast forwarding. Restarting the playback solved it (exiting the movie and returning). I also was able to stop it by pausing and playing again.

Appletv 4k is connected by 1G Ethernet to Synology NAS (dual bonded to 2Gbps).

Video was 1080p h264.

3 Likes

Same issue here too.

Same here, although i very rarely also get this in Plex. Restarting the movie helps in Infuse but not in Plex, there i need to quit and restart the app

So clearly this is affecting at least a portion of users. @james could you give us a feedback about it?

I have seen this issue as well since upgrading to tvOS 15. Restarting Infuse (or rebooting the Apple TV) fixes it for a while.

Most of my content is encoded in HEVC (to save space). It has always played perfectly in Infuse on my 2017 ATV 4K. But, since installing tvOS 15 yesterday, some HEVC files have started stuttering - it looks like dropped frames, the audio continues fine.

The same files worked fine prior to the update.

What’s strange is that 4K HEVC remuxes play without issue and the bitrate of those is obviously much higher than the 1080 content.

Here’s the codec info for one file that was stuttering:

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L4@Main
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 24 min 8 s
Bit rate                                 : 2 604 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.052
Stream size                              : 450 MiB (80%)
Writing library                          : x265 3.4+14-gd419c7152:[Windows][GCC 10.2.0][64 bit] 8bit+10bit+12bit
Encoding settings                        : cpuid=1111039 / frame-threads=3 / numa-pools=8 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=1 / input-res=1920x1080 / interlace=0 / total-frames=34719 / level-idc=0 / high-tier=1 / uhd-bd=0 / ref=3 / no-allow-non-conformance / no-repeat-headers / annexb / no-aud / no-hrd / info / hash=0 / no-temporal-layers / open-gop / min-keyint=23 / keyint=250 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=20 / lookahead-slices=6 / scenecut=40 / hist-scenecut=0 / radl=0 / no-splice / no-intra-refresh / ctu=64 / min-cu-size=8 / no-rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=0 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / strong-intra-smoothing / max-merge=3 / limit-refs=1 / no-limit-modes / me=1 / subme=2 / merange=57 / temporal-mvp / no-frame-dup / no-hme / weightp / no-weightb / no-analyze-src-pics / deblock=0:0 / sao / no-sao-non-deblock / rd=3 / selective-sao=4 / early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=2.00 / psy-rdoq=0.00 / no-rd-refine / no-lossless / cbqpoffs=0 / crqpoffs=0 / rc=crf / crf=20.1 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / ipratio=1.40 / pbratio=1.30 / aq-mode=2 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=1 / overscan=0 / videoformat=5 / range=0 / colorprim=2 / transfer=2 / colormatrix=2 / chromaloc=0 / display-window=0 / cll=0,0 / min-luma=0 / max-luma=255 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / hist-threshold=0.03 / no-opt-cu-delta-qp / no-aq-motion / no-hdr10 / no-hdr10-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=0 / analysis-save-reuse-level=0 / analysis-load-reuse-level=0 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=1 / refine-ctu-distortion=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-analysis-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei / no-hevc-aq / no-svt / no-field / qp-adaptation-range=1.00 / no-scenecut-aware-qpconformance-window-offsets / right=0 / bottom=0 / decoder-max-rate=0
Default                                  : Yes
Forced                                   : No

It seems my same problem.

Same issue here. I’ve had to start using Plex until a new update from infuse. :man_facepalming:t2:

We’ve received a few similar reports on tvOS 15, and it seems to happen with certain TV/AVR/HDMI combos.

This seems to be an issue introduced in the last tvOS 15 beta (and the public release version), and we’re currently working on a solution.

1 Like

James, thanks for acknowledging this. One temporary workaround is to turn off match frame rate in apple tv settings, until your team can fix it.
Cheers

1 Like

If helps you, I’m using Apple TV directly attached to a LG B8 OLED, without avr/receivers. There’s no intermediary there. The Apple TV is connected to a 1gbps Ethernet cable. The library source is a Plex media server running from my local desktop.