Stuttering/Freezing/Image Artifacts

Lately, I’ve been getting a lot of issues with videos stuttering/freezing and showing image artifacts. Initially I thought it was just the file(s) I downloaded, but it seems like everything I download these days is showing these issues. It doesn’t appear to be related to one specific movie or format, though I usually only download .mkv.

My share is set up on a M1 mac mini, data is stored on a 14tb external drive and is shared using SMB, I switched SMB to SMB1 via Infuse but still the same issues. When I run a speed test it’s pretty consistent 90-130mbps, occasional dips to like 30.

Wifi is my only option as there is no way to hook up ethernet to this location, however the wifi is pretty solid and I don’t experience issues with anything else.

This happens with an Apple TV 4k latest model. Anyone have any ideas on what could be going on here?

Did you by any chance try SMB2 and legacy? Also as a test, could you create a favorite on the Macs internal drive and see that is any different?

What MacOS are you using on the Mac?

Hey, I haven’t tried SMB2 and Legacy yet, I will definitely give those a try. I haven’t created a test share on my mac, that’s a good thought though, I will set one up later and see how it goes. If that works I’m assuming my drive might be the issue if it’s working from my mac and not from my external drive

So finally had a chance to get all of this tested, it doesn’t appear to make a difference, tried all the versions of SMB. Created a test share directly on my mac and it was the same issue.

It sounds like this may be a file-specific issue, and if you are able to upload one of the problematic files we can take a look.

Files up to 50GB can be uploaded here.

Hey James can I also upload a file ? I have been having the same issues, some files work flawless then other files studder

I’d guess it’d be ok. just label it so he knows who sent it.

That’s initially what I was thinking but it’s been everything new that I’ve been trying to play. I’ll upload something shortly

i found my issue, for some reason, macOS/external drive was corrupting files as they were being transfered from my mac to my external hdd. Not sure if it was just a glitch or if my drive is dying but erasing now and trying from a backup to see how it goes.

1 Like

To provide more info in case this happens to anyone else, qBittorrent was also causing issues. For some reason once the file was downloaded with qBittorrent and then moved it would corrupt. I switched to Transmission and it fixed the problem there as well.

I was having the exact same issues as you. Use rsync to copy your files to your external hard drive instead of dragging and dropping in finder. Problem solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.