Stutter video playback (or low FPS)

Hey! I am on Big Sur 11.3 and downloaded the latest Infuse 7.

I was on the public beta and noticed a few titles stuttered. It was just a couple of shows, so I thought it must be a bug related to a file format, all good.

Now after the update, every media file is stuttering, or is not smooth. Fast camera movements have little breaks. I play the same movie next to my iPhone and iPad, and it’s all flawless there, but not on macOS.

Maybe someone else has the same problem? It happens with

  • HEVC AAC 5.1
  • H.264 / MPEG-4 part 10 Dolby Digital Plus
  • HEVC Dolby Digital Plus

I have different combinations of files and they all stutter on macOS Big Sur on a Macbook Pro 16" 2019.

1 Like

Hello,

I had that on AppleTV HD with 1080p mkv H264 video AAC 2.0

General
Complete name                            :
Format                                   : Matroska
Format version                           : Version 4
File size                                : 1.08 GiB
Duration                                 : 1 h 2 min
Overall bit rate                         : 2 467 kb/s
Writing application                      : mkvmerge v49.0.0 ('Sick Of Losing Soulmates') 64-bit
Writing library                          : libebml v1.4.0 + libmatroska v1.6.1

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 1 h 2 min
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Default                                  : Yes
Forced                                   : No

Audio
ID                                       : 2
Format                                   : AAC LC SBR
Format/Info                              : Advanced Audio Codec Low Complexity with Spectral Band Replication
Commercial name                          : HE-AAC
Format settings                          : Explicit
Codec ID                                 : A_AAC-2
Duration                                 : 1 h 2 min
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 23.438 FPS (2048 SPF)
Compression mode                         : Lossy
Language                                 : English
Default                                  : Yes
Forced                                   : No

I’m running the Mac version of Infuse 7, again on Big Sur, and its has very jumping frame rate playing 4k content which is easily seen in the various logos at the start of a film like the Lionsgate text appearing from the clouds etc. Non 4k content does not look as smooth as I think it should, buts its hard to tell. I tried the same videos using IINA and they play great.

I did not try the beta version so I can’t comment if this was an issue before of not and I can’t try these films on my AppleTV as its only a HD version (new 4k one ordered).

Same here. Everything is stuttering. Content is x264 1080p with AAC 5.1. Hardware is MBP 15“ 2015 (without AMD GPU)

Problem exists since alpha 1. tested nearly every build. Never had one that worked well for me.

IINA plays everything fine.

I have the same problem but only with 4k blu rays. I have a 16 inch 2019 macbook pro 32GB ram 8GB Vram i9 on big sur. And IINA and VLC are able to play the 4k movies without dropping frames. But I have no problems with regular 1080p movies in infuse 7. My movies are mkv files copied with makemkv and the 4k blu rays are 50 to 80gb each. So maybe infuse 7 has problems with the large file size. I‘ve only tested the last beta for a couple of days and noticed the same behavior. And the app store version has not solved the problem.

There are a few edge cases we have on our radar with certain hardware configurations.

If you are seeing any issues here, I would ask you to please do the following, just to ensure we’re aware of your particular issue.

  1. Submit a report from Infuse (Preferences > Email Us)
  2. Include media info specs for the video, or even better submit a sample
  3. Include details about your Mac (year, model, etc…) in the email

Today’s 7.0.5 update includes a number of core playback improvements making things run quite a bit more efficiently on macOS.

Give this new version a try and let us know how it goes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.