Stuck on 1601 error or "preparing apple tv for restore" msg

My atv2 has the latest iOS. Trying to jailbreak it since seasonpass can do the unthethered jb now but the whole proccess get stuck on those “preparing apple tv for restore” followed by this 1601 error…

I’m running latest itunes on 1.6.7, my usb cable opens itunes when I connect it to the atv2 box, tried different USB ports… I’m stuck…

No XBMC for me?

Well, I got it working… sort of…

Yeah, there’s a story…

After reading this:

I booted into windows and used that ireb. Got an error the first time… Then on the second attempt (this time with both power and usb pluged in, first time I used only the USB) it worked, shit+ctrl got my SP.ipsw into the appletv2 but I got this 1602 error in the end. Well, enough windows for a day, rebooted back to osx.

As I have read a real lot about this shitty error today, I remembered to have read somewhere to try to plug the atv to tv anyway and yeah, despite that 1602, the jailbreak worked.

The boot time was ridiculously slow (I had to reboot it after connecting to the tv) but after some minutes, the settings button with the firecore logo, at last!

I choose to boot it again to check that boot time. It crashed. Second boot attempt and after almost 3 minutes later I see the home screen.

Ssh into it (had to delete the knownhosts on my mac to do it) used the xbmc wiki instructions and after another long reboot, XMBC is there again.

I don’t know if it was just bad luck but I feel the urge to say thank you to the seasonpass team anyway, so thank you guys, it was really messy for me to get it working but it worked.

If seasonpass get updated in the future, for this same atv2 release, should I try to jailbreak it again to get a better boot time? The overall atv response is fine I guess. Noticed some slow loading times for atv default trailers streaming but that might be my connection…

From what I remember, you get 1602 error when the power cord is left plugged in when itunes finishes. Other than that, I don’t think the error means anything.

I got the same problem, tried everything!

My solution was a clean install of ML and then it worked.