Streaming videos from Time Capsule: Need a how-to

I am trying to use aTV Flash to allow my apple TV to stream video stored on my Apple Time Capsule, which is connected via Gigabit ethernet. With NitoTV, this would seem to be a perfect solution for me, as I could store loads of uncompressed video on my Time Capsule and have it accessible in real time, and use a large USB hard drive connected to the Time Capsule as a backup device. Sounds nice, but I haven’t been able to make this work yet. Here are my steps, and I’d love your suggestions on how to get this working:

  • Downloaded and installed the latest aTV Flash 3.3.4 software on my newer apple TV (bought in the spring of 2008). I used only the standard install and not the advanced, as the advanced apps cause my aTV to reboot constantly.
  • Went to the menu DVD > Settings > Network. I see the Time Capsule along with my other two macs as afp shares.
  • Tried to connect and login to my Time Capsule and other macs with administrative passwords. The apple TV reboots and is back to the Network screen.
  • I go to the DVD > Files menu and do not see anything
  • I then follow the instructions on enabling up SMB connections found here: http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer
  • Downloaded the 10.9 Combo Update installer mentioned in the instructions, installed it to the Documents folder of the apple TV with Cyberduck
  • Went to the menu DVD > Settings > Install Software and used the Smart Installer. Once completed I unplugged the Apple TV and plugged it back in to reboot
  • I enabled SMB sharing on my Macs from System Preferences
  • Went back to DVD > Settings > Network and tried to connect to one of my Macs as a test, however I get the following error: error - 1069 = No servers at that address
  • Guest login access has the same info

Here is where I’m stuck. Any suggestions here?

How old is your Apple TV? Streaming from a Time Capsule requires AFP to be enabled, and this can only be accomplished if you have one of the original Apple TVs that shipped with the 1.0 software.

I had gotten the ATV in the spring of this year, after the 2.0 release, so I suspect it is a newer version. What is the best way to check? I thought that these more recent ones could stream using SMB? Am I wrong in this? What is the best way for one of these newer ones to do this?

Not getting any help here… I have confirmed that my appleTV came with 2.0.2 installed. How can I give this access to network drives? If I need the 1.0 recovery.dmg, where can I get it? My searches have turned up unsuccessful.

Yes, if it was purchased in '08, you almost definitely have a 2.0+ Apple TV. Typically Apple TVs purchased before October 2007, or secondhand Apple TVs will be the 1.0 version.

Unfortunately there is no where you can (legally) obtain this software.

It sounds like AFP networking is out then. Is SMB networking possible without the 1.0 recovery.dmg file? So far I have not had success…

Still waiting for a response to my questions, but I did have a thought to propose…

Time Capsule has a USB port and so does apple TV. If I connect those interfaces, would it be possible to stream video via USB stored on Time Capsule?

If I connect a USB 2.0 hub to the Time Capsule, then connect the apple TV, an external hard drive and Time Capsule to the USB hub, theoretically I could use the Time Capsule itself as a media storage device, have streaming capability to the apple TV, and have Time Machine backup of the time capsule data to the external hard drive.

Anyone tried this? ATV Flash: would this work from your standpoint?

Still no word from ATV Flash…

However I believe I did get SMB access working, as I can see the movie files on my Time Capsule. My error: I enabled SMB, but did not setup a Manual Share Point. Once i did this, and restarted the apple TV once or twice, it seemed to work. I found an article that someone from ATVFlash reposted that helped detail the share point fields explicitly and it seemed to work well:

Now I have to figure out how to actually play the files. I’ll setup a new post for that and hope to get a response or two.

Got it working great, thanks to this post. Here’s my summary below:

If AFP Doesn’t work, try this:

SMB Mount

My Setup:

  1. Apple TV 1.0 with latest version of apple software (as of 3/28/09)
  2. Gigabit Home Network
  3. Airpot Extreme Attached via Ethernet w/ 2TB WD Hard Drive (with Video_TS files) attached to it via USB
  4. In the Airport Extreme settings under the tab “Disks” I changed the settings to “Enable File Sharing” and AirPort Disks Guest Access to “Read Only”

Setup Guide from Start to Finish:

  1. Restored Apple TV to original software (1.0)
  2. Booted up, installed latest apple tv software (2.3.1)
  3. Downloaded atv Flash onto patchstick
  4. Unplugged ATV
  5. Plugged in patchstick, booted ATV - Install Successful Message Appears
  6. Rebooted ATV
  7. Go to NitoTV > Install Software > Smart Installer - Ran, Rebooted after
  8. Went to NitoTV > Network > Add Manual Share Point
  9. Entered this Info:

Name: Movies (use anything label want; i.e. movies, tv shows, music, ect…)
Network Address: Kozloff.local (airportExpressName.local)
Login Type: Guest (unless you’ve setup your Extreme to require a password for disc access, then choose registered user and enter the user/pass)
Volume Path: 2TB Black (Enter the Drive Name Attached to Airport Express)

The next screen (on mine) will look like this:

Mount Name: Movies
Mount Type: SMB <-- Change to SMB!!!
Mount Address: Kozloff.local
Requires Authentication: No
User Login:
Password:
Volume Path: 2TB Black
Auto Mount: On <–Change to “On”!!!
Use Custom Path: Off (Change to “On” if you have separate folders on the same drive you want to jump to directly)
Custom Path:
Extra Arguments:

Choose “Save Mount Point.” You can always edit it later.

Now, go to NitoTV > Files > 2TB Black (or whatever folder is mounted) and browse your movies. Worked for me, hope this works for you too.