Streaming via Infuse worse than VLC?

I recently streamed a 40GB 1080p (h264) file from my NAS to Infuse via WiFi. Playback took a few seconds to start. Every now and then (but frequent enough), playback would halt to buffer for a minute or so. After trying a few things like rebooting the ATV and the router, I decided to stream the same file from the NAS to VLC (on the same ATV) and playback started immediately without a single buffering for the whole movie (about 2 hours).

I ran Speedtest on the ATV, and speeds were a steady 500mbps both ways, maxing out my internet plan’s speed. Router is an Asus RT-AX86U just two metres away from the ATV 4K (2nd gen).

I regularly stream files with similar bitrate (or higher) with no issues. This is the first time I ran into this on Infuse.

Can you try running a speed test in Infuse to see what kind of speeds you see?

You may also try adjusting the SMB version in Infuse (found in Advanced section of the saved share’s settings area). Try setting this to either SMB2 or Legacy to see if this improves your speed test results in Infuse.