Streaming iTunes under Computers crash

Seems to be an issue with streaming from an iTunes library. Random crashes during streaming but specifically the following:

During a stream, hold the center remote button until options appear. Click “brose artist” and ATV crashes often requiring manual power cycling.

Environment:

ATV

Mac Mini (10.6.8 with up to date iTunes)

Airport Extreme (latest revision with up to date firmware - N only configuration)

Streaming ALAC or AIFF files

I’m  not sure if this is similar to your problem - streaming from PC library to atv2 thru itunes.  It’ll play one or two songs sometimes and then just stop on the next song…it will have the next song up on the screen but it will never start up…sometimes i can hit the play button and it will start up…other times it will just not start even if i try another song…it just sits at 0:00 . 

I sometimes then have to back out to the atv main menu and then click on Computers (or whatever its named to get back into the itunes music) - then i get the loading logo and it sits there.  Other times i can’t even back out of itunes music…i back out of the now playing area and try to go back to the atv2 main menu - but it gets stuck in the Library>Music> spot - the thumbnails rotate by but i cannot choose a folder to play (I usually have it on shuffle songs). 

Occasionally I have selected the Shuffle Songs and then it just locks up and sits there for a few minutes and then reboots and its back to the main menu again.

I’ve tried to see if its my PC hibernating and have shut that off, i turned the screen saver off (i had it set to reenter my password if it started and thought that may have been the issue but it did not resolve it.)

I have an ATV1 that these issues do not occur on at all.  I don’t even think i had to have itunes running on my pc to have the music stream to my atv1 but with atv2 it seems like i do?

Any suggestions or did the previous poster have any luck since posting?

Still love the product but would be great to have running perfect

Thanks

sorry i’m on atv 4.3(2557) atvflash 1.0; just reading on another site and it seems maybe itunes /atv specific issue not firecore but wondering if there are any work arounds on this end of things.

 

 also if anyone here has similar problems if they’ve resolved with atv 4.4 as some suggest on other sites

Now I am unable to even browze itunes Movies on atv 2 (4.3).  It reboots as soon as I click into movies and try to select any of the options/categories…every time.

Is this a 4.3 issue that would be solved if I go up to 4.4 once the untether is available, or is this a known firecore/atvflash caused issue.  Any input either way would be great.

After a successful move to untethered 4.4 with atv 1.1.1, my movies once again displayed as they should for itunes, and i could browse every item in that menu.  Instead of an ATV logo on the top half of the screen, i again had movie posters.  So that was working as it should.

But

Then I used the backup feature in Maintenance>Settings>Manage Backups to get my addon settings back (really only for my XBMC video addons).  That went off perfectly, all my old addons came back to xbmc.

But

Now, again, my main menu Movies is just showing an ATV logo instead of movie thumbs/posters on the top half of the screen, and again, choosing Top Movies or Genres resets the atv, and Search lets me enter what to search for but it just sits there searching and never finds anything.

The In Theatres option does work with no issues.

Any suggestions other than rejailbrake and manually redo my xbmc instead of restorings my settings?

Thanks

Have you got any menus disabled?  It seems that sometimes this has unbdesireable side-effects

I don’t think so - i do have some in Overflow but none actually disabled from maintenance.

I am wondering now - after i restored my settings , I’m not sure if my Movies wasn’t working from the start or if it was doing this after I tried the Nito Tv weather manager.  It caused me problems in 4.3 as well, and i couldn’t get any of the main ATV menus to show up on the top half of the screen.  I was able to turn off the weather showing up in the top half of the screen and then get the normal images to come back up by doing something in Settings>Custom Settings from another posters thread.

I also just checked as I had moved TV Shows into Overflow and it acts exactly the same as the Movies section is for me - it all reboots the atv

Any other suggestions.?

Disabling menu items using Overflow can cause reboots to happen in apparently unrelated applications in my experience.