Streaming from external hard drive

Hello, so recently after running low on storage with my mac mini, i bought an external hard drive. The external drive is recognized by my mac but when i try and share the folder, it isnt recognized by my apple tv 2. I also tried plugging it into my airport extreme with no luck. Anyone have any idea what could be going on with it? EDIT** I tried another external drive i had just to see if my new one was the problem and i have the same issue?

What format does your external Hdd have? 

i believe it is MS-DOS(fat 32)

If you’re streaming from the Mac Mini you will need to have the drive in Mac OS format.

FAT32 and NTFS formats cannot be streamed over AFP.

What format is mac os format then ? Thanks

Mac OS Plus

It’s also called HFS+ or Mac OS Extended. The drive can be re-formatted in this format using your Mac’s Disk Utility application. Note: Formatting a drive will erase all its contents, so be sure to make a backup of anything you want to save first.



Thanks for replys is there any way i can share my fat32 drive on mac through smb sharing rather than afp thanks again

SMB will only be an option if you’re running Mac OS X 10.6.8 or earlier.

Im running mountain lion so thats out of the question thanks againfor your replys

Guys, I am desperately trying to setup my external HD as a share and I cannot get it to work.
I had dumped it into the shared folders window in Mac OS’ settings, users are proper.
I can mount my Mac under iMac.local as server, but not directly the external drive. Though I cAn browse there through the my data option in the media player. I can even add that specific drive as favorite…
However I don’t want ATV to fetch all data from my complete Mac drives…
I used iMac.local\volumes\media as that is the drives name, but it does give me the error it cannot connect,
Any advice for me? Thanks!

Ahh you guys are the best, thanks formating it to the osx journaled worked perfectly thanks!

Can someone walk me through setup for media player stream to ex hdd, im using win7 with wd 1t hdd cant get the atv2 to see it