Streaming a huge file

Hello,

My plex server is running on a raspberry pi 4, files are from an external hdd, connected to pi4 via usb3 cable. Pi4 is connected to network via Ethernet. Infuse is running on Apple TV 4K, connected to WiFi 5ghz.

I’ve tried streaming a 4K Bluray remux file (88gb) and it went well for the first 15 minutes and loading screen came. Going back 10s and forward 10s would fix it but only for 5-10 minutes, then it’d start loading again. Going out of the video and back in would also fix it.

So I suspect its a buffering issue somewhere but I can’t pinpoint. This is the biggest file I’ve tried streaming so far and the only problem I had. What would the problem be? Is it because of the usb3 connection? Or because Apple TV is connected via WiFi 5ghz? Any tips to debug are appreciated.

What do you get in the speed test in Infuse?

Also, could you post a pic of the graph from the speed test?

It’s best to let it run about the full video to see any repeating issues.

The video was around 3hr and test was taking forever to progress so I stopped it at 3%, here’s the graph:

I’ve found out that the video is 65,3 Mbps - so when speed test goes under it it’d cause loading. Now I wonder what’s the reason for this.

I suspect a bad network connection. Try again using either a wired connection or closer to the access point and see how the speed test performs then.

It would be helpful to run the test a bit longer to see if there’s a pattern. Usually it doesn’t take the same time to run a full test as the movie run time, it’s usually quite a but quicker and a 20%+ may show some clues.

If you can, I’d run a Ethernet cable temporarily just to run a test and see if that makes a difference on the speed test.

Another test if your raspberry pi can do SMB would be to try a connection from Infuse via SMB 2 instead of Plex and see if maybe Plex is throttling things for some reason.

Here’s a test ran to 20% from Apple TV itself:

There is definitely an issue, most likely network. It could be the ethernet cable connected to your raspberry pi or it could be the hard drive itself.

This is the first and only video I had this problem, so it might not be a hardware issue. I’m considering a memory leak plex, perhaps?

Or it could be the file itself. If you run it again do you get the same results?

This would help eliminate the network.

This would help eliminate any protocol issues or Plex settings problems.

  1. Restart the router, Pi. and Apple TV.
  2. Run test again. If no change, connect Apple TV by Ethernet. Run test again.

This will,l if nothing else, rule out the most common and easiest to fix problems.

2nd test ran to 24%:

Unfortunately I’m not able to run an Ethernet cable to Apple TV.

Restarting devices yields the same result

Here’s another file (23.76GB, ~3hr) speed test ran to %37:

Average speed was 94mbps.

Is the raspberry pi limiting you to 100Mbps Ethernet?

Here’s what I see on Plex dashboard while the video is playing on Apple TV app (without any loading):

image

ethtool eth0 | grep Speed gives Speed: 100Mb/s

The router (Fritzbox 7583) is configured to provide Gbit access to the LAN port but raspi is not using it. Possibly because of the ethernet cable?

Still nothing explains the speed drop happening when playing this file. Other file doesn’t have this, and network is fast enough to play this file if the speed didn’t drop. My curiosity only increases…

Yes that could be it. You definitely will want to have over 100 to support all 4K. File might be 65 average but peak can theoretically get to 128 or something like that.