Stream from External Hard Drive to Infuse

Hi

I have a MacBook Pro and connected to it is a Samsung T5 which contains TV shows and films. The files are streamed to ATV4. The current set up I use Plex Media Server. Everything works fine with no issues.

However, I want to avoid using Plex, but I cannot get Infuse to connect to the T5 and I get the error ‘access denied’. I have check file sharing and the T5 is set up correctly. I have tried this on the iPhone, ATV, iPad and I get the same problem.

Do I have to connect with Plex in order for everything to stream properly, or have I missed something obvious that needs to be done?

Thanks

I don’t have a clear idea what you’re doing wrong, but it’s definitely feasible because that’s how I set it up.

I almost never have the need to stream media from outside my home network, so instead of NAS + Plex, I just store the media in an external drive, set up a SMB share on my MacBook and access it from other devices connected to my home network, including Infuse on my iPad and iPhone.

Welcome to the forum!
There’s some info here on setting things up in Infuse


You may have better luck if you set up a new user/password specifically for your ATV to connect to your MacBook. I’d suggest using SMB but you’ll have to enable SMB sharing in the options in the Sharing panel on the Mac.

Hi there - Yes I am sure that I have had it set up without using Plex in the past. I have triple checked the sharing panel and I have toggled ‘only allow SMB encrypted connections, I have applied ‘permissions to enclosed items’ and ensured everyone is read & write. Oh yeah, and enabled "share files and folders using SMB’.

The only thing that comes to mind is that the external drive is formatted as APFS???

APFS shouldn’t be the culprit here. I vaguely recall that you need to not only enable “Share files and folders and SMB”, but also add your user account below in “Windows File Sharing”:

Yes I have dont that too :slight_smile:

Okay - I found the problem! I was dragging the whole external drive over to the folder sharing panel when I only needed to add the folders that I wanted to use.
Everything works now!

Thanks guys :smile:

2 Likes