Strange Display in Movie Library Sort By Age Rating [SOLVED]

Noticed today that on infuse 5.3 when in the “Library” favorite, under “Movies” then “By Age Rating” I have the follow list exactly including duplicates.


I’m not using the new age restriction function and it’s still turned off as it was when introduced.

When I look at both duplicate ratings for each one they both show the same movies.

Any ideas on what is causing the duplicates?

Glad to know I’m not alone in seeing this issue as per my post earlier.

What setting have you assigned to your metadata language?

Same as what I had from before the 5.3 update, English (United States).

Has Infuse completed a full scan since updating to 5.3.1, or what is the current status shown in the Settings > Library menu?

Been trying to not get too anxious checking for the 5.3.1 update but if there’s a chance it will address this I’ll go pester my ATV and see if it’s available for me yet! Will let you know!

Whoops - I meant 5.3, but 5.3.1 was just approved by Apple and is rolling out on the store. So you can give that a try too. :wink:

Gee, and here I was thinking that your post was a “nudge, nudge, wink, wink,” that 5.3.1 had been released into the wild by Apple. LOL

And yes, I had let it finish a full scan (actually a couple of full scans) but will try it again when 5.3.1 appears.

Sounds good.

If you are still having trouble, sending in a report from your Apple TV wouldn’t hurt. :wink:

Okay, the 5.3.1 update did not cure the issue of double listings for the age rating but I did find out where the issue lies. I have 2 shares that have duplicate movies between the two. They aren’t exactly the same content of movies but several are the same between the two. As soon as I went to the settings screen for Library and removed the check from one of the two movie shares the Age Rating correctly showed only one rating and not double on most. All of the rest of the Library/Movie choices like “By Release Date”, “By Rating”, By Genre" etc all have the correct single choices under them even with both movie shares checked in library. None have doubles like the “By Age Rating” had. They did show 2 of the same movie in the list but that’s fine, it’s just the library sorting by Age Rating that is having a problem.

So, while it appears there is a bug in the way it shows Age rating with multiple shares with similar movie content it’s not a crisis.

Hey, ya got to have a reason for 5.3.2 :wink:

Just an update.

It appears that the double listing in the library of specific age ratings is caused by having one or more movies duplicated in different shares. I spent a bit of time running through the possible combinations and found that just having movies on multiple shares is not an issue. The duplicate rating happens when you have even one duplicate out of hundreds on different shares. If you have duplicates of a movie that’s rated PG then you’ll have PG listed twice in the library movie sort by age rating. If you have duplicates that are rated PG-13 then PG-13 will be listed twice and so on. As soon as you remove either of the duplicates and let the library finish the updating the age rating in library for that movie will no longer be listed twice. You do have to remove ALL duplicates that share the same age rating in order to get the library to show that age rating only once.

If you have several hundred in different shares it could be tedious to find the duplicates but if you select that age rating in the library you can scroll through and it will show two entries for the movies that are duplicated so that makes it a bit easier.

It’s defiantly a bug but not a major one.

The reason for my duplicates is that I have some movies “backed up” to multiple drives on different systems just in case one goes south I can still have a little entertainment till the repairs are complete.

James, if I can help clarify this convoluted rambling in any way let me know.

Just to wrap this up. After several hours of trial and error along with thoughts of sacrificing a chicken on top of the ATV, with the help of james I solved the issue. Deleting the shares and then reinstalling them did the trick, now even with duplicate files in multiple shares the Movie Library function of sorting by Age Ratings only shows one listing for each rating instead of doubles.

Thanks james! (for some reason it took deleting the shares twice to get to the end result but hey, it’s only voodoo.

OK, as i still have the issue, i will try deleting the shares and adding them back in. It doesn’t make sense that this issue didn’t exist before 5.3, but then again, the Metadata language was always set to Auto before this release on my setup.

The way I understood it was that with 5.3 there was a ton of overhauling to the library and database handling. I was skeptical too but since I had to kind of start from zero again anyway the deleting and redefining shares wasn’t as bad as I was prepared for. Now regardless of how may duplicate movies I have across multiple shares and favorites the Movies library sort for Age Restrictions now only shows one for each rating I have movies of.

Good Luck!

All right, I’ve had some time to play around with this further based on the advice above and the result is still unfavourable.
Deleting the shares and adding them back in again did not resolve the problem.
I cleared the metadata and rebuilt from scratch again after doing this. I still have duplicated rating categories when viewing this Age Rating filter in the library.
Very annoying!