Status update required

Hi ATV support,
could you please issue an update on the status of the latest build and the issues that many of us have encountered, including unrecognized external drives, Adobe Flash not working, etc. Although it’d be nice to have the fix available now, what’s more important is that we know that you’re working on the fixes, hence the communication request. I’d suggest that if a fix is not estimated to be available in the next week or so, that you make a previous stable version available so that we can continue to enjoy the product.
Thanks!

Cheers,
Neil.

For a direct response on a specific issue it’s best to send an email here: http://www.atvflash.com/contact.php

I’ve outlined a few guides that may help resolve the two things you mentioned.

USB Storage
http://wiki.atvflash.com/index.php?title=USB_Storage

Adobe Flash
http://wiki.atvflash.com/index.php?title=Enable_Flash

Will do (I avoided creating yet another ticket since so many folks have raised the issue of Flash not working in the latest release so I’d assume that the problem is well-recognized. I have followed the steps you provided the links to a couple of times unsuccessfully (and with minor variations on the theme all to no avail). )

At the same time though, I think it would be beneficial to issue a general statement on the discussion board about where the troubleshooting of the current release is since so many customers are experiencing issues. I also think that it would be helpful to make prior releases available so that the functionality can be restored until the current release is updated. Please advise. (It’s not so much of an issue for me personally as I’ve only just purchased this product and don’t have any legacy apps or data, but I think that the general approach as used by many other products of having multiple versions available means individual users are able to land on a version that is stable for their particular situation.)

Thanks!
Cheers,
Neil.

Enabling Adobe Flash in Firefox and Boxee has always been a bit tricky as a special framework must be manually located and installed. There is a note about this limitation here: http://forum.atvflash.com/viewtopic.php?f=19&t=3000

That being said, even with Adobe Flash properly enable the resulting video playback isn’t that great. This is due to the limited processing power of the AppleTV, and is mentioned in the FAQ section on the main atvflash.com site.

If you’re having trouble feel free to send an email and we will do everything we can to get you back on track.

As luck would have it, I located the appropriate version of CoreAudioKit.framework, installed it on my (old) Apple TV with the current version of Apple TV 3.0.2 and ATVFlash 4.1.2?, and Adobe Flash now works in Firefox. FF prompted me to update which I’ll do but not before making a note of the version I have now.
So, I won’t create a ticket as my issue is resolved. I do have the 10.4 installation disks but elected to use a version from online that worked as it was easier to download it.

Cheers,
Neil.

Great.

FYI, aTV Flash installs a 2.x version of Firefox which seems to be the best option for the AppleTV. You can update if you like, and can easily reinstall the original version by removing and reinstalling Firefox as described here: http://wiki.atvflash.com/index.php?title=Maintenance_Plugin#Install_Extras