sshd disabled / not installing?

Hey guys,

I noticed recently that ssh can’t be enabled on my AppleTV anymore.

I remember updating my AppleTV to 2.4, then installing aTV Flash 3.6.1 which seemed to go fine - everything worked ok. But I noticed I couldn’t ssh to the appletv. When trying to ‘Enable ssh access’ from NitoTV, I get an error like the following in my console log:

“Could not enable SSH… sshd missing”

So I installed AppleTV 3.6.2 to try and fix the problem, but it didn’t seem to help (although the install said it went fine, I got the new plugins manager, version numbers updated, etc). Still can’t enable ssh.

I’ve tried re-running the ‘Smart Installer’, it says everything is installed. I tried going to the plugins manager and selecting ‘nitoTV’, it told me nitoTV was installed and up-to-date.

Anyone got any ideas? Will try a factory reset if I need to, but is this a known problem?

SSH is enabled by default. We have a guide for connecting via SSH/SFTP here:

I have the identical issue operating version 2.4 on the ATV. Going to check info on post above. We shall see.