SSH Connection Refused


I've apparently successfully jailbroken and done a tethered boot on my aTV as it's booting up and connecting to my network just fine, however it's refusing my ssh connection leading me to believe it's not actually jailbroken. Is there any other way to test and see if it's properly jailbroken? I've tried factory restoring > jailbreaking twice now (so this is my third "successful" jailbreak), but I haven't had any luck. I've tried ssh and ftp via Terminal to both Apple-TV.local and to the AppleTV's local IP address directly and each time I get:


ssh: connect to host <address> port 22: Connection refused


ftp: Can't connect to `<address>': Connection refused



EDIT: Adding that I tried removing all traces of seas0npass once along with any copies of the ipsw floating around on my computer before the most recent attempt, however I couldn't get seas0npass to redownload the ipsw so I think I missed it somewhere.


I have spent most of the day with this exact same issue.  I am surprised at the lack of information there is about this specific problem and beginning to wonder if this is a new problem as I bought 2 apple TVs yesterday when I learned that XBMC was ported.  I hope that this is not something new on newly bought apple tvs.


As with the other poster, I am able to jailbreak using seas0npass.  As far as I can tell I am also successfully booting tethered (seas0npass gives the proper messages about successfully booting).


No matter what I try - I cannot ssh and get connection refused.  I tried from windows and mac so I don't think it is a firewall problem on the computer.


I am wondering rivals, did you just purchase your apple tvs? or have you had it?

I got it right around Christmas, a few days before to be exact. I hadn't tried jailbreaking until today due to a lack of a proper USB cable and lack of serious interest until I heard about the XBMC port the other day. Really hoping I can get this figured out soon though.

Same problem here.  Successfully completed jailbreak using seas0npass and then booted tethered.  SSH connection refused using terminal on mac as well as putty and WinSCP on Windows.  Connection refused in every case.

Add me to the list. I spent about 4 hours and several attempts. I know something installed successfully because my ATV required a tethered boot, but once it started up I could not ssh in, it was just a plain old ATV.

One of my big complaints about seasonpass is that I could not find where it was storing its created image file so I could inspect it myself. It would be very nice if the authors (1) gave me a choice on where to save this file and (2) allowed me the option to simply re-use the previously generated file rather than to generate another (a very time consuming process).

So far I can't say I'm very happy with the whole ATV scene, hopefully the new un-tethered jailbreak coming for the iPhone will trickle down and make the ATV experience a whole lot better.

I'm glad to see I'm not alone, I was worried when I didn't see any other threads about the issue and no amount of searching seemed to help. I really just wish there was some way to confirm that it's successfully jailbroken other than ssh/ftp.

I am also having the same issue.  I am required to tether boot, but I have no ssh access....  Anyone have a solution?

this happens to me.

Sucessful path/restore. Then did tethered boot, booted up fine, but cannot ssh in, responds to ping not ssh, tried user root and frontrow .. nothing =/

tried again from scratch and still no luck. does anyone have any ideas?

Hi all,

I'm trying for several days now to jailbreak my atv 2 with seas0npass an pwnage tool. Finally I the jailbreak with seas0npass did work and now I have the issue like you guys. No ssh connection on my Mac. Not with Cyberduck, not with the terminal. I've searched a lot through the Internet and I found two possible solution. But both of them haven't worked for me. But probably for one of you guys:

First: Many posts in forums the answer to connection refused port:22 is to activate the remote login in the preferences (System Preferences > Sharing > Remote Login > Start): 


Second: Another guy posted a howto for getting XBMC on atv2 (I want to this too). At the end of his post he posted a troubleshooting tip for the connection refused message:

As a side note, I had issues getting my MacBook to connect to my AppleTV via SSH. I kept getting connection refused or invalid host errors. There is a file on your Mac you can delete in order to stop these errors (not sure where it would be located on a PC if anyone wants to chime in here). You’ll need to unhide files on your Mac first. You can do that by following the steps below.

1- Open Terminal and type (or copy/paste): defaults write AppleShowAllFiles TRUE and hit “enter”.

2- Type (or copy/paste): killall Finder

That should unhide all of the hidden files on your Mac. Now you should be able to navigate to /Users/username (in my case Ally)/.ssh and delete the file titled “known_hosts”. It should be the only file in that folder. Then try the above steps again.

Only some of you may need to do this but I figured I’d throw it in there for anyone who has issues connecting via SSH to their AppleTV.

Sharing is Caring .. »



I hope this does help some of you guys. If anyone finds a way to get this working I would appreciate a post in here.



about 15 minutes after posting here i ended up using PwnageTool with the unofficial 4.2.1 bundle, worked a charm first go, took like 5 mins, and now have xbmc.

just followed this article

Giving that a shot now. Thanks.

8 times no luck (errors 20, 21, 1600) but than it worked. I finally got XBMC running - Thanks a LOT!!!


SSH connection refused means the jailbreak didn't work properly. Keep on trying its worth it!


Btw: The video did help a lot.


followed the docs on that page and it worked the first time. so much for seas0npass.. a dozen attempts and it never worked once. either it wasn't creating the firmware file properly or it wasn't pointing itunes to it. ssh was available the instant pwnagetool's firmware booted up.

Add me to the list.  I ran Seas0npass twice (restored through itunes between jailbreaking attempts), but still can't ssh in.  Tried using mac Terminal as well as Putty on my windows machine.  Same problem:

port 22: Connection refused

I'm gonna try the pwnage tool tonight and see if I can make it work that way.

I got my Apple tv 3 days ago, so it's brand new.  I wonder if there's something with the new ones that keeps Seas0npass from working?  Is there a way to rollback to previous firmware?


If you're seeing this issue please try re-jailbreaking with the latest 0.6.9 (36). You can check the version through the 'About' menu in Seas0nPass.

After this if you're still having trouble please submit your debug log as described here:

I'll try that when I get home tonight.  I'm not sure which version I downloaded, I think I got it from (thats the site i was using to guide me).


Anybody with the same problem try this?  Did it work?

This worked.  One step I realized i didn't do the first time (or did wrong) was this...

5. When performing a tethered boot timing is important. The power cable should not be connected until you see the rapid flashing light. Additionally, the HDMI cable needs to be connected promptly once the tethered boot process is complete, and before the white light on the AppleTV stops flashing.

Thanks for the help!

So in summary,

  1. I had the SSH Connection refused error.
  2. I downloaded the most recent version of Seas0npass from this website:
  3. Then I follwed the unlocking steps word for word here:
  4. Then I ssh'd into the apple tv and installed XBMC using the instructions here:


Great. Glad you're back on track.  :)

PLEASE help us…i was loving my ATV2 SO much thanks to all the hard work the coders at FC have been doing. but i am severely disappointed with the 4.4.4 JB i cannot reinstall all my faves, even though i can connect via cyberduck…but no ssh…?

please help???

and thank you.

I was able to jailbreak atv2 as untethered. When plugged in to the TV, there was the FC code watermark. I was also able to use Putty to install NitoTV and had no problems setting up XBMC. However, when I tried to use WinSCP to upload some files, it gave me a network connection refused. Tried many times and even used Cyberduck with no luck.

Any advice. I know that I was able to access the ATV2 thru Putty initially.