SSH Assistance

I installed the new untethered jailbreak with firecore (no issues), I installed NitoTV through the program - Putty (no issues) and now my issues begin. I understand that XBMC may not be available yet for this new version, but the other issue I am having is now I can’t get back into the AppleTV through Putty. I am trying to install XBMC through Putty but for some reason i’m getting an error “Server Unexpectedly Closed Network Connection”. I find this weird when I was just working with Putty not even a full day ago and now I can’t get back in. I even checked to make sure the IP address hasn’t changed and it hasn’t. Also, I have disabled firewalls and tried restarting the computer and apple tv with no luck.

 

Can anyone help here?

 

Thanks in advance

Now NitoTV has totally disappeared off my AppleTV screen…what is going on here? lol

I have fixed all my problems with this. 

 

This can be deleted

How did you fix your problems? I’m having the same issues.

 

Thanks

me three… started after I did a apt-get uprgrade, and it upgraded the openssh

 

now i get:

ssh_exchange_identification: Connection closed by remote host

Actually it was pretty easy.  I just “un-jailbroke” the apple tv back to original 5.0.1.  I then “re-jailbroke” it using seasonspass.  After doing that, I was able to SSH into my AppleTV first try using Putty.  Instead of going the NitoTV route, I just did the XMBC code and now its all running fine.  I then loaded 1channel into XMBC using WinSCP. 

 

I will keep you updated if this one eventually fails on me

Same thing happened to me.  I’ve jailbroken twice.  SSH and WinSCP seem to work for a little when then out of no where I’m unable to connect with putty or winSCP.  I have two apple tv2’s.  Both are successfully jailbroken.  I even installed plex without any issues, but now I cannot connect into either.  If anyone figures this out, please let me know.  I hate to keep re-jailbreaking and then having an undetermined amount of time to ssh then no connection.

AT

Well that’s not good.   I wonder if it’s just a bug that needs to be worked out.  Maybe someone can answer this question.  Originally when I was looking up how to SSH through putty, this was one of the lines it gave me to enter

"wget -O- http://apt.awkwardtv.org/awkwardtv.pub | apt-key add -"

What character would that be between the .pub and apt-key?  

Might be a stupid question but I don't know lol

That symbol is a pipe and it shares the button on your keyboard with \ .  Where do you insert that code?  I doubt it will help per I’m unable to use WinSCP to connect either.  I get the same exact error.  I think it’s a bug that hopefully will be discovered soon.  Otherwise I recommend getting a list of things you want installed, re-jailbreak and get them installed before the door closes.  Once they are in, they are in, but no chance of changing or updating once the door is closed. :frowning:

AT

getting the same issues
Error:    Server unexpectedly closed network connection
with any Sftp-ssh software i been using

sure it’s a bug with NitoTv with openssh

i have the same issue. do u have any idea to fix?

We you “re-image” your Apple TV your devices identification may have changed.  SSH freaks out when this happens and known_hosts has to be cleaned up.  For Mac/Unix/Linux this is easy to fix below.  I only know how to do it for windows with the below.  Maybe someone else knows how to clean up putty known_hosts without losing all the configs.

 

For those using Putty on Windows try dropping to the command line: Start–>Run–> cmd

C:> putty -cleanup

 

If you are using a Mac/Linux and SSH from the Terminal:

cd ~

vi .ssh/known_hosts

(Now find the line that shows the IP address of your Apple TV and move to it)

dd

(dd removes the current line)

:wq!

( write and quit)

 

Try again…

I tried above command but no help. I don’t think its putty problem, as the problem atv can’t accessible from any SSH from different systems.

There is a larger thread been dealing with this for days. We think it is a worm which was affecting iPhones etc - Ikee.

To solve this problem, you have to re-jail break and then before you add anything, change the password using Putty - get in with root and alpine and then type passwd

You will be prompted for a new password and then again to make sure you’ve entered it ok. Once you have done this, it is ok to install everything else. 

The problem has not returned since I did this and one other who had the problem too.

Good luck.