Speed of apple TV 4K on LAN is ~ 150mbs/s is ok for 4K HDR 90gb/file?

I copied files from a HDD to my laptop is at 80mb/s (~ 650 mbs / s). But I use speedtest in my ATV 4K is ONLY at about 150mbs/s much lower than may LAN SPEED. HĐD is min at usb 3.0 and giga switch, cat6 lan wire. I don’t know have problems with my LAN sys or APT 4K is only that?

And for a perfect LAN SYS to play 4K HDR DOLBY (my be 100GB/film), my LAN should be much speed test (by nagative app in APT4K)?

I believe the max bit rate for a 4K Blu-ray is 128 Mbps so 150 should be good.

1 Like

That speed e we will be perfectly fine

I am not sure if I understood completely, but if with “speedtest” you mean the app “Speedtest by Oookla”, the bandwidth reported is your internet bandwidth. That doesn’t affect the internal LAN bandwidth, the one needed to transfer the movie from your file server (Mac/PC/NAS/ whatever) to Infuse in your ATV 4K.

The internet bandwidth could be even less than 1 Mbps (125kByte/s) and the 4K movies would stream just fine assuming your LAN uses 1Gbit ethernet connections (which should be your case).

You need an high Internet bandwidth (and 150 Mbps is way above the world average) to stream at 4K from apps like Netflix/Amazon Video/YouTube etc. because their server are in the cloud (internet) and not in the LAN.

No, this has nothing to do with internet speed. There is a intranet transfer speed test built into the software.

I’ve been asking myself the same question over the weekend as I noticed some stuttering and on looking at the server (OMV) it looked like there was a 100mbit connection somewhere and the link was fully saturated (74GB file), but I’ve put a laptop on the same cable and can well exceed the 100mbit that the ATV4K was utilising. My router also confirms the connection to the AppleTV4K is 1000 full duplex.
Running the speedtest just now from within Infuse, I get an average of 170mbit when using the same 74GB file.
Is this a true speed test as the transfer rates are nowhere near what a laptop on the same connection is showing?

Those are your actual transfer speeds for the file you are testing.
A transfer rate of 170mbs should be more than enough. I’m assuming that your hard wired and not using Wi-Fi.

  1. is the stuttering only on certain files or file types? mov, mkv, bdmv etc…
    1-b) is the stuttering only on 1080p or 4K or 4K UHD etc…
  2. have you reset the router.
  3. are you updated to the latest version of infuse?

Apologies, I’m not attempting to hijack this thread, just trying to get to the bottom of what seems to be a very similar issue which will hopefully benefit us all.

When I connect my laptop to the same cable that the Apple TV 4K is using, I can get 800mbit copy speed or more, so why does infuse only copy at 170mbit. Is that a limitation of the Apple TV 4K or the way Infuse is doing the network testing.
Yes, this is a wired network. I did try the same test via wireless and was getting about 120mbit transfer speeds via Infuse.
I’ve tried both NFS and SMB connections on the Apple TV 4K and get exactly the same speed on each protocol, which are less than 25% of what my laptop can pull across the same cable when accessing the same shares on the same server.
I haven’t updated infuse, I didn’t think you could force updates on TvOS? Mine is set to auto update, so assume it’s running the latest version based on how long it’s turned on a day.

Infuse doesn’t need a full pipe to play the movie it only needs the speed it draws to play the movie and still fill the buffer as needed.

And yes, you can force an update on ATVs if there’s one available.
Settings > System > Software Updates > Update Software.

Thanks Bullseye.

I assumed this was the Apple TV OS updates only, not apps.

Apple themselves don’t make any mention of forcing updates using the method you describe when automatic updates are enabled;

And with regards to the way you describe Infuse doing it’s speed test, it’s not really a speed test if it’s only transferring at the speed it needs to to play the file and fill the buffer. A true speed test should transfer at the maximum speed the network infrastructure or hardware are capable of.

The max through put speed is not the issue, it is more likely that Apple has a software limit on throughput.

For steady playback, staying above a minimum speed threshold is more important than the max. ex: Constant speeds above 75 MB’s should actually provide good playback.

If your having buffer issues see if it is consistent and if it happens after 5 min 10 min etc, of movie playback. Then run the speed test, then look at the graph. When looking at the graph your looking to see if you have drops in speed. This would be more consistent with a buffer issue.

If you see drops in speed that’s usually a router side issue not infuse or the AppleTv.

Also identify if it only happens on certain files or file types.

I believe the speed test was implemented to test specific files so the user could test that specific file to see if their network would support that file’s required speed to play without errors dropouts, or getting the buffering wheel during playback. Some of the HD content requires more than what that device can pull over say a weak WiFi link or a poor Ethernet connection so this test will check that specific file using it’s requirements. If the test was just to see what the max was it wouldn’t need to specify a specific video file.

As to the update for infuse, I apologize, I misread what you were saying. you can do an update for Infuse by going to the App Store on ATV and then “Purchased” > Entertainment > Select the version of Infuse you have (Either “Infuse 6” or “Infuse Pro 6” and click on it.

If the button on the page you go to says “Open” you’re current and if it says “Update” you can click on it and update to the latest version. You can also scroll down on this page and see what version is current in the app store since they may lag a day or two behind when FireCore submits updates to Apple.

I mean speed test by INFUSE PRO 6. You come in Library win see “check speed”. And INSFU 6 in APT TV 4K is lower than may LAN speed very much.

Ahhh. Ok, I didn’t know about that option. I just checked, I get an average of about 170-180Mbps. Which is quite low, but it’s also true that usually the bitrate of 4K videos is quite below that. I tried in the past test videos at high bitrate and I had buffering with the ones with a bitrate of 250Mbps or above. The 120Mbps video plays fine (just tested now).

Anyway, you should check the bitrate of your video (if you have a Mac you can download “mediaInfo”, there is a free version) and not just the size. If it’s 120Mbps (which is above the max bitrate of a UHD Blu Ray movie) or less you should be fine.

this is not my experience. i too had issues with playback (which turned out to be a poor cable so was not negotiating a 1Gbps link). Even when i fixed the issue the SMB and NFS performance was not stella but waay higher than any normal 4K file would require (200-250Mbps). When i moved to FTP as a protocol i immediately maxxed out the connection and the speedtest returned 950Mbps. I have never looked back since.

However, none of the stats I observed lead me to believe that this was what “infuse needed to play the file” rather than a real speed test. FWIW… the poor SMB / NFS performance i did not investigate any further…

open up an FTP service on your NAS (if you can and switch that, you will have a much better experience. i have no idea why the speed test returns such mediocre results with SMB / NFS

Switched over to FTP tonight and bang - 950Mbps speedtest throughput.

Happy with that as it proves everything is working as it should be, so will leave it on FTP now.