Speed has decreased drastically recently

Hello there

Since today, my speed has decreased recently on Infuse, preventing me to finish watching a 82 GB movie in 4K HDR. A speed test gives a result of 33 Mbps of average speed, over 2 minutes. I believe I used to get 90. Ut I’m not 100% sure.

My ISP is giving me 300 and I roughly get between 250 to 300. I did speedtest on Apple TV (via the Speedtest app), I did fast.com tests on my iPad Pro and Mac mini and everything is around 300 Mbps. I even restarted my router.

I don’t know what else to do. Any suggestions?

sounds like your remote server may be throttling your speed or network traffic is slowing things down.

Getting 30 Mbps is really about the absolute minimum speed for plain videos, not 4K or other high bandwidth videos.

What does the graph look like in the Infuse speed test for this video? Run it to 100% to get the best indications.

Thanks for your reply. I couldn’t run it to 100%, would that help diagnose the issue?

You might need to download & zoom on the picture to see speed values.

My remote server is a Mac mini M1. Everything was working fine yesterday, I could watch the 1st hour of movie. Now, it’s unwatchable.

I didn’t change anything in my network between today & yesterday. I thought there was a new update of the app released recently but I don’t know if the update was made today or a few days ago. Not that I blame the new version but I’m very lost on this. I’ll try again tomorrow.

I ran a longer test this morning and it looks better:

I noticed a drop, as you can see. Should I be worried?

I know wifi is not the best but so far I used Infuse for 2 years with no issues. I can’t put ethernet unless I ask my ISP to add a new optic fiber plug.

Is 70 Mbps sufficient for 80 GB 4K HDR streaming ?

No, 4K blu-ray spec goes up to 128Mbps so higher is better.

I have a similar issue which I presumed was due to a change of broadband provider, but now I am not so sure.

For several years I used ethernet to connect from server to router and from router to Apple TV 4K. This worked fine and I could stream 4K without any buffering at all. I also tried going completely wireless and (to my surprise) I could also stream 4K perfectly over WiFi via a Plusnet broadband router.

Then I changed to Sky broadband with Sky Hub router. Broadband speed was increased from 60 to 100 mbps as this was full fibre. However, in terms of local streaming over WiFi (and ethernet) this is now slower and I am getting buffering. WiFi is out of the question (buffers every couple of minutes) and even via ethernet it’s not great.

I am unsure whether this is due to poor WiFi performance on the Sky router (compared to Plusnet) some other settings which are wrong, or possibly something which has changed with infuse which is causing my 2015 MacBook Pro to run slower than before when streaming?

Strange though that at least two other posts this week have also been related to slow speeds and buffering?

Maybe I need to buy a better router, a new Mac (perhaps MacMini) or even a the latest Apple TV with larger memory?

Some speed tests within Infuse would be pretty good.

Here’s my thoughts. Plusnet are pretty stable and use the BT routers(their parent company) which for an ISP provided router is just about as good as it gets.
Skys router however is absolutely awful having just set one up for a non tech friend.

You don’t mention it specifically but is the media stored locally or is it remote?

I personally have the latest gen Apple TV 4K with 128GB so it allows me to buffer anything in my collection fully. But again an indication of how the speedtest behaves (peaks and troughs or constant but slow speeds) will help possibly to reveal more clues.

1 Like

I have not used a internet providers router in many decades. I learned early on they do NOT want to deal with individuals fine tuning equipment for their specific needs, they give the very basic level of quality and they will often lock and or not publicize the ability to change settings to improve WiFi or basic networking functions.

The expense of a well known brand of WiFi/Ethernet router and the ability to tune ALL of the settings has far outperformed what the ISP provided. Well worth the cost and set up time.


Thank you for your input, much appreciated.

My media is stored locally, stored on USB connected to MacBook Pro.

Currently via WiFi for HD streaming the Sky Hub is doing OK. With 4K however it needs it to be wired. My current (rather convoluted) workaround is to use an ethernet cable from my MacBook to the Apple TV. Then (if I want to watch a 4k movie) I just click the cable into the Apple TV. Obviously there is no internet access but it does stream the 4k movie perfectly well. For logistical reasons at present I am unable to run an ethernet from the router to the Apple TV.

Speed test results are:

WiFi - iOS - Ave 39, but lots of peaks and troughs between. I am therefore unable to watch 4k on Infuse iOS

WiFi - Apple TV - 33 mbps !!!

Ethernet (MacBook Pro to Apple TV) - 300Mbps

I think I might invest in the new Apple TV (128GB) with (presumably) faster processing. Also a new router may well be on the cards I think.

Strange through that my broadband speed test (over WiFi) confirms download speed is 107mbps and the video speed test confirms all should be OK for streaming 4k (which of course is true unless I happen to be streaming local content with uncompressed 4k video and full HD audio!)

Thanks again for your help :+1:t3:

You didn’t mention how the files are being shared from the Mac to Infuse, but if you are using Plex Server, I may have a possible solution. If you don’t use Plex Server on the Mac then this won’t help at all.

I was having a very similar problem a few months ago. It turns out plex server has an option where you need to specify your local network address range so it knows not to throttle it for internet connections.

I notice a low speed too, my internet connection is full fibre 900mbps and my router is Asus GT AX11000 the 11000 being it’s max wifi throughput via 3 channels, one 2.4 and two AX 5ghz channels, one 5ghz channel is disabled, and it takes about 3 - 5 seconds to get 100mb downloaded, but the theoretical speed I should be getting is 866mbps. Divide by 8 and I should be getting roughly 100MB give or take per second, but what I’m seeing is closer to 30MB.

I’m not moaning, just wondering about it since other folk mentioned it.

It just takes slightly longer to download stuff from my server to my ipad pro, no way would I stick a 80 odd gb bluray on to my ipad, it would poop its pants if I forced it to eat that amount. :joy:

I do have a legit problem but I won’t post it here so the thread doesn’t come of the rails.

I definitely agree with what @NC_Bullseye recommended. When I upgraded from my ISP-provided router to a Synology router, I noticed a dramatic improvement in Infuse’s loading times - even though I had everything connected by Ethernet in both setups. It’s not just the WiFi speed you have to worry about in an ISP-provider router; the processor inside it will be very slow as well, which really slows down things like streaming to Infuse.

This is what I use, it’s been excellent: https://amzn.eu/d/jbdSbBN

Many thanks for the advice, I will look into to getting a new router :+1:t3:


Do you think I can plug my Apple TV in Ethernet to my Mac mini, while using wifi? Does that make sense? I can’t plug ethernet to my router as the router is sitting by the sofa.

Infuse Pro speedtest is around 60 Mbps.

I connect my MacBook to Apple TV via ethernet to stream 4k blu-ray rips. It works fine with 300 mbps speed. You will lose internet though. I only plug the ethernet in to watch via Infuse. Otherwise (with the cable removed from the Apple TV) it will revert to WiFi. A bit of a faff but it works for me :+1:t3: