Specific Film Metadata (and how to correct artwork?)

What would be the strategy for fixing bad artwork in a Library? The metadata is correct but the artwork is bad.


It Comes At Night (2017)
Johnny Dangerously (1984)
Hush (2016)

I probably have about 25-50 movies like this out of 2900.

It almost looks like whoever you scrape from has a banner art listed in the Posters section.

Probably the best way is to join www.themoviedb.org and look at the ones in question. There you can help make changes for any that are incorrect in the format.

I thought that was it but looking at themoviesb.org I don’t see the screw up in question.

For instance, none listed for the first film look like the art chosen:


This wouldn’t be caused because the artwork is too big right? Like 2000x3000 formats…


Is it possible that your file has embedded metadata?

And have you tried to edit the metadata and re select the correct movie?

It’s possible, but I do have embedded metadata off in case. I have tried refinding it as well.

Figured it out, although it might be a bug? Basically I have a few movies for example called:

It Comes at Night (2017).mkv

and its corresponding poster was:
It Comes at Night (2017) - 1080p.jpg

When I changed the movie over to the " - 1080p" convention it worked. So that to me means something in Infuse is tripping it up if it finds a local jpg but its not the same name. Thoughts?

Could you remove the .jpg file and see if it finds the right one on themoviedb?

As a side note, files with a dash symbol “-” seem to create issues often. I’ve had problems in the past on the Mac OS and Infuse relation with dashes and I just removed all of them in video file names. None of those issues have resurfaced. The dash in the .jpg file may be interpreted as a “do not include” when matching jpg to movie.

I’m defiantly not a programmer but I’ve been irritated to the point of wild exploration by several of them. :wink:

1 Like

One other thought, are you accessing files from a plex set up? Plex seems to take perverse pleasure in modifying file names and watching infuse stumble around trying to figure out what the heck it’s supposed to be.

I am using Plex, but in Infuse I use SMB. I am OCD about file names though, so Plex can’t touch that. Ember Media Manager is what I use to get metadata.

Did you see my other post just above the one you quoted?

Ya, I will test it out and let you know if its a bug or not. Getting rid of the dash might be harder than I want it to be, too many apps I run would blowup if I rename stuff.

So it looks like if any file exists in the folder it wont fetch the metadata properly. My test:

Dawn of the Dead (2004).mkv
Dawn of the Dead (2004) - 1080p.jpg
plus other files

  1. Removed the .jpg, still didn’t work
  2. Removed all the other files (.nfo etc) still didn’t work
  3. Removed folders like extrafanart and .actors so the mkv was by itself. - Worked
  4. Added my own .jpg named correctly - Worked and switched to local jpg