Spatial audio for AirPods Pro

I‘m on the newest Apple TV 4K with the tvOS 15 and when I pair my AirPods Max and turn on spatial audio in Infuse or even with shows from Apple TV+ I still get sync issues that some posters described before.

Am I the only one experiencing it? As soon as spatial audio is turned off the audio & video are perfectly in sync so I assume it can only be Apple‘s fault? But that wouks be a pretty big bug in the release version and render the feature unusable.

Mid / Late Sep. What’s current planning date for 7.2?

Plex must call native apple player (they called old video player),and it supported video encoder is limited. For case, your downloaded video is encoded with non - supported codec, it will transcode at server side. which need a very powerful computer.

Looking forward to see Infuse solution on this…

If you have an iPhone you might want to give the Wireless Audio Sync feature on the ATV a try. I’m trying to get my hands on an iPhone so I can test it out.

Thanks for the tip with the iPhone syncing mechanism in the settings. I didn’t know that.

What ultimately seems to have solved the problem is a setting inside Apple TV called match framerate. Once I turned this off the (spatial) audio was perfectly in sync again with the picture.

A post on Reddit on the feature

Curious, what TV do you have? I haven’t played around with spatial audio since one of the betas in the summer, but the match framerate setting never did much for my setup.

No sync issue with spatial audio on my Apple TV 4K (2021) running tvOS 15. And I use march framerate and match dynamic range. On a 2018 LG OLED.

You never had to run the wireless audio sync either?

I actually did run the wireless audio sync as well but that alone didn’t fix the problem. I think it must be some weird bug in combination with the LG OLED.

Awesome news, really looking forward to this! Can you already share if there are special requirements (in terms of codec, channels etc.) to get Spatial Audio?

No special requirements. :slight_smile:

The upcoming 7.2 release will support spatial audio for all audio formats and channel layouts. Of course, videos with multichannel audio tracks are going to have more immersive sound than those with just stereo/mono tracks.

3 Likes

Spatial audio is now available in Infuse 7.2! :tada:

4 Likes

Thanks for your efforts.
I tested the feature with some test tones, and it seems Atmos by DD+ is recognized as only 5.1 DD format on Spatial Audio.
Is this a limitation of Apple API?

In 7.2, Infuse supports multichannel spatial audio for all formats.

We’ll be looking into advanced handling for Atmos (E-AC3) tracks in a future update.

2 Likes

Glad to hear that. I’m looking forward to see an update.

Amazing!

To the Devs, are there different virtual “rooms” in spatial audio? The one with Plex old player has much less reverb and sounds more in your head than the ones in the native Apple TV app and now infuse.

To anyone having sync issues, use the wireless sync calibration. The problem with OLEDs is that different refresh rates have different delays. It’s annoying so I keep everything at 60hz now

1 Like

Using Plex’s ‘old player’ simply uses Apple’s native player, which gets spatial audio automatically. This player is very limited with the formats and features it can support so it’s not a viable option for Infuse.

The implementation in Infuse 7.2 uses the latest APIs from iOS/tvOS 15, which I suppose could perform differently than past APIs from iOS 14. Apple has been pushing spatial audio pretty hard since WWDC, and there have been quite a few technical changes in iOS/tvOS 15.

Of course, the actual videos you’re playing can have an impact on how things sound, as different titles have different channel layouts and mixing.

1 Like

Excited to give this a go! I was finally able to dink around again this week with my Airpods and can confirm that the wireless audio sync and keeping match frame rate off seems to have mostly fixed lip sync issues. I swear that TV+ still finds a way to screw up sync though. As mentioned above I have an LG OLED as well (actually 3 of them lol).

Working great so far. I’ve played parts of Arrival (DTS 7.1) and Baby Driver (TrueHD Atmos) and it’s a go!

3 Likes

Yes, same for me but I notice that when I turn Match Framerate off that then I get the soap opera effect in an infuse movie. It seems that one is always step behind.

I fumbled around with the TV settings but didn’t really grasp where this is coming from.