Sound missing high and lows (seems like not full dynamic range)

Hello,

I have an Apple TV 4k and Infuse Pro, both in their latest version.

My audio settings are set to ‘AUTO’ and ‘Best Quality Available’, as suggested in other topics on this forum. The option ‘Reduce loud noises’ is set to OFF.

When I play a movie with TrueHD, it seems like there is a really big difference from my PC with passthrough ON. In theory, TrueHD → PCM that happens inside Infuse should be a lossless transition, but for sure something is off. The bass is really not punchy and the highs are not that high.

In my PC the sound is cristal clear and sound as it should. In my Apple TV setup playing exactly the same file does sound like the “dynamic range” for sound is not set as “FULL”.

BTW, if set ‘Reduce loud noises’, the sound is even more muffled.

Any ideas?

I’ve searched the web and found some problems similars as the one I described here, but everybody said it was fixed in the 10.2 release.

Thank you very much

Welcome to the forum!

Is your Apple TV connected directly to the AV receiver via HDMI, or are you going through another device (like a TV) first?

Another thing you may check is the settings on your receiver, as some models allow for different volume/EQ settings depending on the source type (Dolby, PCM, etc…) or input (AV1, AV2, etc…).

Lastly, if your videos have multiple audio tracks present, you may want to check and ensure Infuse has selected the one you are hoping to hear. This can be done through the Audio tab of the Playback Menu (swipe down while a video is playing).

Thanks for your quick answer James!

I have a Yamaha RX-V677 and I don’t think I can set EQ based on source types, only in inputs. My PC and my Apple TV are hook up directly to the Yamaha using HDMI.
In both inputs I’m using “straight”, that is, not EQ is done by the receiver.

I downmixed a small sound sample from Dolby from TrueHD to AC3 but there is no difference, still fells like “limited dynamic range” when plyed using Infuse. If yoou want to download it and test it by yourself: https://we.tl/t-lLle7nG6yI
Please, play this MP4 on PC an than on Apple TV while keeping the exact same settings in your receiver,

The file as only one sound track.

Thank you again.

We actually used the Amaze trailer (both lossless and lossy versions) as a reference file when testing new features in past updates, and IIRC no issues came up. We were also comparing the lossy version played in Auto mode to lossy played in Passthrough (before it became unavailable in tvOS 11.3+) and the results were identical.

A few more things you can check.

  1. Play the video in Infuse, and bring up the your Yamaha’s Info onscreen menu (attached is an image from an RX-A1050 which I believe should look like yours). You want to make sure you’re getting PCM with all the original channels, and not something like 5.1 Dolby Digital or 2.0 PCM.
  2. Try cycling through the DSP modes to see if you can find one that sounds to your taste. These, I believe, can be set differently for each input.
  3. You can also try downloading a few sound check videos (https://thedigitaltheater.com/tools/) which will allow you to confirm the audio channels are all going to the right place.