Sorry, the installer could not install Maintenance (Error 4.2). Help!



I get this message from Installer when I try to install aTV Flash RC1 :

Sorry, the installer could not install Maintenance (Error 4.2). Help!


I can not update Maintenance from the manage settings meun


Apple tV2 is running 4.3


Anyone got any ideas?

Can you post your FC_installer log file found in your Documents folder?

Here it is 


<log removed>

I am running into the same error.  Below is my log.


Nevermind I got mine working.

I am facing the same error too, log here:

<log removed>

and, yes I have xbmc installed too.

Based on your log, the best thing to do may be re-jailbreak with the current version of Seas0nPass then install aTV Flash (black).

Once aTV Flash (black) has been installed extras like XBMC can be added through the Maintenance menu.

I’ve resolved mine.


Running the last command manually it showed the error bellow:

Apple-TV:~ root# apt-get -y install com.firecore.maintenance

Reading package lists… Done

Building dependency tree       

Reading state information… Done

E: The package org.xbmc.xbmc-ios needs to be reinstalled, but I can’t find an archive for it.

Apple-TV:~ root# 


So I removed this with:

dpkg --remove --force-remove-reinstreq org.xbmc.xbmc-ios


and then the atv flash black installer worked.


It might be because I moved over from the org.xbmc.xbmc-ios to org.xbmc.xbmc-atv2 and there was something left behind?

Yep, the XBMC change was probably the cause.

Glad you’re up and running though.

Yeah good idea to run it via Terminal. Got the message:


E: Write error - write (28: No space left on device)

E: Can't mmap an empty file

E: The package lists or status file could not be parsed or opened.

Connect via WinSCP and delete some Cache files from:




Great advice! I just rm’ed the hell out of the cached files and was able to update. Thanks a million!

i have the same problems. How do you guys enter terminal mode to manually give commands?


Yes worked for me too. Thanks all

James I’m having same problem, please help.