Some subtitles won't play...

Hello!

 

I’m a new ATV Flash user and I’ve been using Media Player for a few days now.

It’s great but there’s a strange problem/bug I’ve been dealing with and I’m not being able to figure it out…

I use media player to watch some TV shows I download and usually add a subtitle file. It’s the “regular” process I believe most people do and I’ve been doing for a long time now.

The problem is that the subtitles will only show in some of the files when I play it with ATV Media Player (the same with XBMC, with same files). Some other files the subtitles work perfectly. It’s very strange.

The files are located in a shared folder in my Mac and the strangest thing is that when I play the same few files (whose subtitles don’t work) directly on the Mac (with VLC), the subtitles work perfectly there, but not in ATV.

I wonder if it’s a problem with permissions, I shared the folder with read/write permissions, I don’t know if that’s enough or not, but for different files on the same folder I get the subtitles working for some and not working for some others.

I’m not a very advanced user, to be honest, but if you can help me, that would be amazing!

PS: even though not a “very advanced” user, I’ve checked the basic things, like naming the files the exact same name (I’ve even tried to name the files A.avi and A.srt to be simple enough for me to be 100% sure they were exactly the same, still not working)…

Thank you!

Have you tried downloading other subtitle for the same movie, and see if the new one works?

You can try “Jubler”, that’s an app for mac to load subtitle files, you can maybe load it there and save as.

Hi there!

 

Thanks for your help, but I finally managed to solve it.

The subtitles files permissions werent set right.

Somehow the subtitles files I download from www.podnapisi.net are set by default with no reading permissions (except for the local computer) so the ATV is of course unable to see them. I just have to set reading permissions for these files and it works!

 

Thanks again.

Thanks alot nmartins! That solved my problem too! The answer seemd so locigal, but I couldn’t figure it out myself.