Some shows not syncing with thetvdb

I’ve noticed the following 2 shows (which have large numbers of seasons and episodes) are not fetching metadata from thetvdb even though the shows are listed:

  1. Modern Marvels -
  2. Saturday Night Live -

Has anyone had issues related to these shows? I’ve tried naming and arranging files as per instructions found in the metadata 101 article (including adding the year released with the title as mentioned in other related posts)

It also appears that the Modern Marvels season and episode data found on thetvdb is not matching imdb (i would include links but limited due to being a new user)

Any suggestions/advice will be greatly appreciated.

Welcome to the forum!

Could you provide an example of how you have one of each of the series episodes named?

Also, Infuse doesn’t currently use IMDB for any info so all references for TV series will come from TVDB and all movie info will come from TMDB. (This will most likely be changing very soon but that’s how it currently works)

Edit to add: For The first the file names should be like

“Modern Marvels S01E01.mkv”

and for the second

“Saturday Night Live S01E01.mkv”

Edit 2

Also this is the file structure that works best for me so far.

I currently have the files and folders arranged as you suggested with no luck. Have you tried creating a new file with the names you suggested and got it working on iPhone or Apple TV app?

I realize IMDB is not used by Infuse. I just want to bring attention to the difference in Season and Episode numbers in relation to the shows Title.


the only difference I see is it looks like you are file sharing from a macOS and i’m on windows 10. I know it works since the show American Restoration is working but still no luck with the others. here is a screen shot (i’d seen more but restricted to one due to being a new user):

here is file structure screenshot:

I just manage things from a Mac, the files are on a Synology NAS using an SMB share.

Do you by any chance have use local metadata selected for these two?

You can check following the users guide here.

If so you need to turn it off.

Also with the right names and file structure, have you done an “edit metadata” and reselect the correct show? That may reload everything.

Edit to add: I went back and changed mine to use local metadata on an iOS device and it looks like you may have Use Local Metadata selected, if you long press on the main show folder it will give you this screen.

If your top choice is “Use Online Metadata” instead of what mine shows (Use Local Metadata) that means you have Local Metadata selected and Infuse won’t fetch online info. Tap the Use Online Metadata.

Thanks for the fix and quick response, Bullseye! I did like you said and searched for the show name via “edit metadata” and it worked!

1 Like

You’re welcome! Glad that you got these snags fixed, I know it can drive you nuts when you have a few shows that just don’t want to cooperate.

Just out of curiosity were they set to Local Metadata too?

Edit to add: I noticed on your screen cap from your phone that on Modern Marvels S13E02 it appears that you don’t have a space between the name and season. If you miss that it could cause problems with that episode fetching info. :wink:

No. I had tried to edit and search metadata before and it synced the wrong shows/data. I think I was trying to add specific show AND episode titles. I prob didn’t have same file structure at that time either. Finally got all the stars aligned so I’m happy. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.