Some MP4 files give "an error occurred loading this content" error message

I’ve performed a diagnostics upload and tagged this post to the data. Hopefully this info will help identify the issue and help anyone else having this same problem.

You may want to post the 5 digit code here in the thread too.

This is true. My files that get the error play in other media player straight through to the end. It only seems to be infuse where I’m getting this issue. It’s annoying because although it’s been suggested to re encode the files. It would take me lots of man hours re downloading my media from mega encoding and re uploading.

I agree Lukeowen2000. If the suggested solution alone is to perform weeks of re-encoding then that would be a show stopper for me.

I’ve had this issue, I’ve found it to be my router. I’ve resolved it by resetting my network. Here are somethings that have worked…

  • Run the speedtest via Infuse to test connectivity to your USB Drive.
  • Make sure your ATV and USB Drive are on the same network.
  • Make sure internet access is available via the router.
  • Restart all your network nodes, router, and modem one at a time starting with your modem, router, and then nodes.

This issue started for me after a firmware update on my ASUS router. The router wouldn’t allow authentication to the USB Drive without internet access. This was my setup in my RV. I was able to fool the router for those times when internet was unavailable by connecting a WiFi booster. Even though the router still didn’t technically have internet the WiFi booster somehow fooled the router.

I now have a Mac Mini in my RV and share the Hard Drive from the Mini. I’ve never have had another issue, unless I’ve mistakenly mismatched my network settings on the ATV and/or the device my hard drive is connected to.

Good Luck

Okay so I think I’ve completely fixed the issue on my end. I compared a selection of the movies and shows giving me the instant “An error occurred loading this content” message and noticed that they all had special characters in the file names.

So when I file was titled like this it failed to load :point_down:
Star Wars: The Phantom Menace

However when I removed the : and refreshed infuse, the movie now shows the quality and audio rages which were previously not there. And the video plays.

So I’d advise anyone having these issues to check the titles of your files. This may not be the fix as my issue was specific to mega.nz. When I copied the exact same file to gdrive it loaded like normal with infuse. For some reason mega doesn’t like the illegal characters like : ; ! Etc…

Hope this helps some of you out.

Thanks for the suggestions. I switched away from using SMB in favor of trying FTP. Sure enough, the files now play perfectly. So the problem was not the files as I originally suspected.

My only conclusion is that there must be a bug in the Infuse client when operating over SMB, or something specific to my hardware. I see a number of other people posting similar issues here and in other threads, so hopefully the diagnostic logs I’ve submitted will help the dev team to find the root cause at some point.

Hey @lukeowen2000, are you also the tester for tvOS or specifically macOS? I’m happy to help diagnose anything further if it’ll help?

Did you try any of the different SMB protocols? It could have been that SMB3 was throwing a security error. If anyone else would try changing from “Auto” to “2” and try that then, try “Legacy” to see if either of those two may help.

@NC_Bullseye - “Did you try any of the different SMB protocols?”
Yeah correct, I ran through all the SMB version options, including Legacy mode. They all had the same result. Hoping SMB can be fixed, as it’s definitely a more preferable protocol over FTP.

@lukeowen2000 - “So I’d advise anyone having these issues to check the titles of your files.”
I thought the same very early on, but when I noticed that even “Jurassic Park” wouldn’t play, that eliminated it for me as a potential cause.

@munpip214 and @james - I got a reply back regarding the diags I uploaded. They said the following:

It looks like Infuse is receiving a ‘file not found’ error when attempting to play certain files.

The files in question do exist of course, but for some reason certain files come back with the “file not found” error. It would seem the client is able to scan the volume for directories and filenames in order to know which metadata to fetch, but when it tries to read the contents of the files themselves it runs into this error. Any thoughts?

Are you able to identify a correlation between the location of the working files compared to the non-working files?

Can you try moving one of the non-working files into a folder that contains working files, just to see if that makes a difference?

Hi @james. Yeah I thought a similar thought early on. I looked for correlations between which directory they sat in, if the file had non-alpha characters in the name, if the filename was particularly long, whether the affected files were part of a “bad batch” of overnight encodes that were maybe impacted by a different version of Handbrake or Kdenlive. Everything I tried to replicate or remediate the suspected causes, the results were completely inconsistent. The files themselves existed across 5 directories, but in each of those directories there existed both working and non-working files. I checked if the files were perhaps close to the 4GB file size limitation of the FAT32 schema, but even then that turned out to be a false lead. In the end however, no one thing resulted in me being able to say “this” causes "that.

Worth noting, but possibly unrelated, before switching to FTP I also tried reformatting the host drive to Exfat, but this made no difference to the above test scenarios. That was when I had the thought to try a totally different protocol (i.e. FTP).

Hmm, ok.

Have you had a chance to submit a sample using the link above? That would allow us to rule out any file-specific issues.

Hi @james, I’ve tried to recreate the issue in a non-copyrighted file a few times, all without success. I can’t upload any of the original affected files as they’re all copyright. I guess it stands to reason that if I cannot replicate the issue in a non-copyrighted file, then it’s possible the original cause could be resolved (e.g. a former bug in Handbrake/Kdenlive now resolved).

For those who encounter same issue with remote video streaming (vpn, FTP or any other outside lan) I suggest to check router settings. It might be called differently but for ASUS it is IPS (intrusion prevention system) enabled. I spent 2 weeks to understand why my appletv runs movies through my 3G shared from iPhone and is unable even to try to do the same on 600Mb fiber….