Some issues about the typeface input

The subtitle are lack of some of the typeface, so i download that sort of typeface and install it to the ios, but when i try to add it to infuse it doesn’t work, I clicked it on the menu it doesn’t do anything, humm… :thinking:

What type of subtitle file?

Edit to add, did you restart your device after adding the fonts?

When you say

What do you mean? Nothing happens, or just the new fonts don’t show but you still get the font menu?

(need 5 characters :sweat_smile:)

yes, the typeface I install do show up, but when I click it in that add font menu in the infuse it just doesn’t work, font doesn’t change, and still says I am lack of font

I tried it, still :frowning_with_open_mouth:

Yes, this method can only be used for .srt. You have to embed the font.

In your .ass file you will want to check the exact variation/name of the font being used, and ensure that is the one being installed on the system.

There can also be multiple styles set in each subtitle file which can often times have different font names set.

Here is one example style section which defines two subtitle styles. The first uses Microsoft YaHei and the second uses Bauhaus ITC.

[V4+ Styles]
Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, OutlineColour, BackColour, Bold, Italic, Underline, StrikeOut, ScaleX, ScaleY, Spacing, Angle, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, Encoding
Style: Default,Microsoft YaHei,22,&H00E1E1E1,&H0000FFFF,&H00000000,&H00000000,0,0,0,0,100,100,0,0,1,1,1,2,5,5,-38,134
Style: E,Bauhaus ITC,12,&H00E0E0E0,&H00C0C0C0,&H00000000,&H80000000,0,0,0,0,100,100,0,0,0,1,1,2,5,5,3,134