Some files stopped working via pass-through?

Set up:
Source: Infuse Pro 6 via Apple TV 4K. Files hosted on a local NAS.
AVR: Denon AVR-X4500H
Display: Sony VPL-VW295ES

Something happened around 09/16 (just before TVOS14) that has made some of my files impossible to play via pass-through to my projector. If I change the AppleTV’s settings to not match frame-rate etc. than everything works fine. When I try to play my 4K Planet Earth II files or certain 1080p MKV files, the Denon can’t seem to understand the signal and playback stops after about 1s of audio. The screen is black and the projector shows that the main input is disconnected. If I press menu on the apple tv remote to return, everything comes back to life. There does not seem to be anything wrong with the files and there’s no pattern in frame rate, colour depth or resolution.

So far I have tried various output options in the Denon AVR and I tried upgrading Infuse, but nothing has solved the problem. I have also tried removing and re-adding the files to Infuse. The Denon is in enhanced signal mode and so is the projector.

I’m at my wits end with this, can anyone please help me?

Any chance you could plug your denon into a different screen/monitor? I’m wondering if your projector is having issues syncing frame rate. Or possibly there is some hdmi cec control that is taking over and pauses stops the playback. You could try removing from all other hdmi to denon.

I also have 4500, 4K Lg OLED, but on Apple TV HD and no issues there.