Some 4K movies stuttering on ATV4K. Maybe hardware/software limitation?

The original issue described in this thread is actually related to a specific video (Star Wars 4 A New Hope 4K77.mkv), so if you are seeing this with a different file there may be something else going on.

If you have a chance to send in a sample we can review here it could be helpful.

Samples (up to 20GB in size) can be uploaded here.

Strangely, when I finished downloading this file last night I loaded it up to just test it out real quick and it seemed to play just fine in both Infuse and the official Plex app (though it had to transcode the DTS-HD audio).

Now this afternoon when I tried to load it up to actually watch it, it is now stuttering in both apps. I did just update Plex Media Server so I wonder if that has anything to do with it?

There was another post awhile back from someone who experienced something similar, and they were able to trace it back to a high amount of disk IO activity on the computer they were streaming from. During periods of low activity everything would play fine.

Perhaps something similar is going on in your case?

Ok, will do soon when I get some time. In the meantime, can you talk about the ability to force transcoding, like the native plex client? Doing this solves the problem for me, though I realize it’s not ideal, it is the solution I’m currently using, which means as of now, I can’t use Infuse because it doesn’t have that ability (that I’m aware of, correct me if I’m wrong though).

File uploaded… note this file plays fine on everything but the Apple TV 4k and iOS. LMK and thanks

movies in 1080P must you the videosettings on 50hz. and UHD movies 60hz. I hope that Apple this problem wil fix it soon.

Did that file help show anything James? tia

Thanks for the upload.

Yours seems to be a related issue…looking into this.

Any update on this, James? I have the same issue…

This is still on our radar, and something we will probably be able to look into once we wrap up the 5.8.2 update which (among other things) is geared towards getting a few things tuned up for iOS/tvOS 12.

FWIW, this issue is only present with a few select files that have been improperly encoded.

Thanks James - I appreciate the update and fast response! I can’t speak to whether the encoding is proper or not but the same file plays flawlessly on my LG TV from a USB drive. That’s not a good solution for me, though, so I’m holding out for improved compatibility with Infuse, which seems like a great product - hopefully it will come fairly soon… Keep up the great work!

I went ahead and re-encoded 4K77 and now it works flawlessly with AppleTV and iPhone. I used all the same settings (same bitrate, H.265, etc) so there should be no perceived quality loss compared to the original. Contains 5 english audio tracks and the subtitle track.

Here’s a link for a .dlc file that contains all the links to download it (movie is ~88GB, 500MB splits).

  • Link removed by mod *

Moderators, feel free to remove my post if it violates any policies.

I went ahead and re-encoded 4K77

Why would Star Wars 4K77 suddenly work on the Apple TV 4K with Infuse after a re-encode?

i.e., what is different about the re-encode vs. the original, jittery version? Lower bitrate?

I don’t know. It just does work now. I didn’t apply noise reduction, no cropping, matched all the settings to the original file, kept the bitrate identical, etc. The resulting file size is the same.

edit: I did find one difference between the two files, but I’m 95% sure this wouldn’t fix/cause any playback problems. My re-encode’s video’s profile is Main10 Level 5.0 while the original’s is Main10 Level 5.1 (apparently Handbrake can’t output HEVC at 5.1). However, every UHD Blu-ray is encoded at Level 5.1 and they don’t have any playback issues on tvOS and iOS. ¯_(ツ)_/¯

Also good news, the new 4K83 release plays perfectly!

“4K83” plays back for me, but I’m unable to scrub through the video. I was watching it for around 20 minutes before i stopped playback to do something else, and I’m unable to seek through the file. I guess I’ll rewatch the first 20 minutes again haha.

More info for anyone who might be checking in on this thread.

I have the exact same issue with the same file (Star Wars 4K77 2160p) on the same hardware (Infuse 6 on ATV4K, streaming from Mac Mini) and I am 99.9% sure the error is this: THE HEVC STREAM DOES NOT CONTAIN FPS INFORMATION.

If you inspect the file with any kind of stream analyser (eg. demux tool in tsMuxer) it reports “HEVC stream doesn’t contain fps field”. This would’ve occurred when the file was authored. In every single other MKV file in my media library, I am going to assume the fps field for the video stream says something along the lines of ‘23.976’, thus ensuring buttery smooth playback.

My educated guess is Infuse is unable to determine the FPS as a result of the missing info in the HEVC stream. This is not an Infuse or hardware problem, but an issue with the file.

Question to the Infuse team is this: can we force an fps setting (or default it to 23.976fps) when fps info is missing from the video stream?

Interesting theory José, but MediaInfo recognizes it:

Video:
English, 89.4 Mb/s, 3840*2160 (16:9), at 23.976 (24000/1001) FPS, HEVC (Main 10@L5.1@High)

Dang. Right you are, RiotNrrrd. My MediaInfo says the same thing. Interestingly:

• I’ve tried this same file on VLC and MrMC also. Every app exhibits the same behaviour as Infuse.
• The 1080p version of 4K77 works fine. Looks and plays beautifully (but it’s not 4k, obviously).
• The 4K83 release—which is ROTJ 35mm scanned by the same team—works fine in Infuse. It has a slightly lower bitrate than 4K77 and is encoded as HEVC Main 10@L5.0 High (4K77 is Main 10@L5.1 High).
• tsMuxer’s stream analysis tool still reports the stream as missing the fps field. Suggests a potential encode issue?

Perhaps this file is just too much for the ATV4K to handle? Wouldn’t surprise me if the next Apple TV handled this file without any issues (because upgraded CPU/GPU).

Sorry I should have updated you guys

It’s the encoding of this film. If you use ffmpeg to simply re-encode this film using the copy command it fixes the issues.

My 4K Apple TV now plays it flawlessly over WiFi ac. Note the mbit is truly the highest I’ve seen at 85-95.

I also downloaded the dnr 4K version. Couldn’t handle the noise.

Just FYI everyone, 4K77 has been updated a few times (currently at v1.4) and everything newer than v1.0 plays flawlessly. 4k83 is also at v1.1.