Some 4K movies stuttering on ATV4K. Maybe hardware/software limitation?

I have an Apple TV 4K wired up with a gigabit connection to my server.

Some of my 4K videos will always stutter even without subtitles and with basic stereo or DD5.1 audio tracks. Also doesn’t matter if it’s HDR or not.

The only similarity I can find between them is their bitrates can go over 100Mbps.

Is this possibly a limitation of the hardware or the software? Another issue entirely?

1 Like

I’d try a new Ethernet cable and probably at least a cat 6.

For the first time in my live not long ago I had an Ethernet cable that failed and not a hard failure, it cut my speeds almost in half. New cable, problem solved.

It’s definitely not an issue with that line’s connection speed.


Here’s a video showing the “stutter”

Maybe it’s not even an issue with the bitrate? Maybe some sort of rendering bug?

1 Like

4k Star Wars? Does it happen on any 4k material which has been officially released? Just wondering if it’s a problem with the source file.

Off the top of my head, I have had similar glitches with Bridge on the River Kwai and Zero Dark Thirty but only in a few scenes and not nearly as extreme as this example. Here’s the MediaInfo for this Star Wars movie for what its worth:

General
Complete name : /Volumes/Media Server/4K HDR Movies/Star Wars 4 A New Hope 4K77.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 82.0 GiB
Duration : 2h 2mn
Overall bit rate : 96.1 Mbps
Movie name : Star Wars 4K77 (2018)
Encoded date : UTC 2018-05-23 05:35:32
Writing application : mkvmerge v23.0.0 (‘The Bride Said No’) 64-bit
Writing library : libebml v1.3.6 + libmatroska v1.4.9

Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
Codec ID : V_MPEGH/ISO/HEVC
Duration : 2h 2mn
Bit rate : 89.4 Mbps
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.450
Stream size : 76.3 GiB (93%)
Title : Star Wars 4K77 (2018)
Language : English
Default : No
Forced : No

Audio #1
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Format profile : MA / Core
Codec ID : A_DTS
Duration : 2h 1mn
Bit rate mode : Variable / Constant
Bit rate : 1 642 Kbps / 1 509 Kbps
Channel(s) : 2 channels
Channel positions : / Front: L R
Sampling rate : 48.0 KHz
Frame rate : 93.750 fps (512 SPF)
Bit depth : 16 bits
Compression mode : Lossless / Lossy
Stream size : 1.39 GiB (2%)
Title : English Stereo (1977 35mm mix)
Language : English
Default : No
Forced : No

Anything look odd? The file plays perfectly fine on my computer, even over WiFi.

Tomorrow I’m going to put the movie into an M4V and MOV container. Maybe it will play nicer with Apple’s software.

We have had a similar report with this exact video, and are looking into what we can do to resolve this.

FWIW, in the past we’ve addressed similar issues for videos with incorrectly ordered frames, and it’s likely there is something similar going on here as well.

Stay tuned.

My 2cents… under AppleTVs own config -> video and audio -> match content (Matcha innehåll)… change from Off to ON… it may flicker between 50/24 every time you start an app or video depending on TV etc but after I changed it to ON I could watch Black Panther 4K (hevc) (streaming from my QNAP NAS) onto 1920x1080 (FHD…not 4K) Samsung TV and Apple TV 4 (not Apple TV 4K) without stuttering. If Match Content is off, it started to stutter on that 4K movie… (and as I doesn’t have a 4K screen there is no obvious reason to download 4K for me… this was just one of the simpler tests I did with diff 4K sample videos with Infuse and my Apple TV 4).

But I know there are many other 4K videos that aint able to pull it thru due higher bitrate etc… for that Apple TV 4 K would be needed as A10 can chump hevc directly…

My other 2cent… If it is a ”pirated copy” of a movie that seems to have a problem I would suggest the possibility of a copyprotection scheme used… the movie “John Wick” have a “funny” copy protection scheme that results in a copy were the chapters are changed! Why not the possibility of a copy protection scheme that jerks with the frame rate or otherwise?

I always keep that setting on.

The Star Wars movie is a fan-made film scan that is distributed exclusively through torrenting for now. In the case of the other movies, the glitching is far less noticeable in Infuse and doesn’t appear at all during playback on other devices.

Thanks! This was the first video where I’ve seen this “glitch” this severe. Hopefully it’s nothing too difficult to find the cause.

I also get the same janky movement with this exact video. Also happens in the Plex app and MrMC.
Does not happen in VLC for tvOS, but it does stutter/drop frames there.

Wow, that’s janky. Does it only happen at that particular point in the movie? Or does it happen randomly in many different places?

Just as a control, I’ve put it on a SanDisk USB 3.0 stick and plugged it directly into my 2016 LG OLED6EP and it plays perfectly - so far. (I stopped it at the Canteen scene, so I didn’t get as far as your stutter glitch point - but I had zero problems up until the point where I stopped playback.)

P.S. I’m keenly interested in this issue as I have an  TV 4K coming in a few days and the first thing I’m going to do is buy Infuse 5 Pro for it. Would rather play 4K77 off of my Mac mini’s RAID via Infuse on the  TV 4K than have to stick a USB stick in the TV all the time.

Any update on 4K77 UHD playback?

The only way I’ve been able to watch it so far is with a long cord to my i7 win 10 desktop, but then DTS doesn’t work so I end up on the non-DTS '83 remix audio, and to be fair the whole reason I got the ATV4K and Infuse was to stop doing nonsense like that!

I got an Apple TV 4K over the weekend, and immediately purchased Infuse 5 Pro and installed it.

My initial reaction is mainly favorable (it played most of my test files I threw at it) but when it came to 4K77, it failed miserably.

I got the janky stuttering pretty much from the get-go - opening scroll.

Of course, the problem now is that there’s no way to know if it’s an Infuse problem, an Apple TV 4K the-hardware-isn’t-good-enough problem or a playing-an-80-Mbps-file-over-Gigabit-Ethernet-off-of-a-Mac-mini-Thunderbolt-attached-RAID-box problem. Or (d) all of the above. :-/

1 Like

I’ve had the file playback well now in a few places - MPV on Linux, Windows 10’s built-in Movies, and now off a USB to an LG 4k OLED. Its funny the LG specs say it only does 50Mbps HEVC max but it had no problems at all playing it.

I tried re-muxing it with latest MKV tools and reduced the audio tracks to just the 3 main english DTS ones (stereo, 5.1, mono) but that didn’t help with Infuse on ATV4K playback. I tried hardwiring to my main 1Gbps switch too but also no joy.

MPV doesn’t show any real errors - just one or two during the crawl but otherwise it seems pretty happy with the file.

James,

Any update on this by chance? Appreciate your help.

This video is apparently just encoded poorly. I get choppy playback on my PC as well.

Windows/Mac? VLC/some other player?

It’s weird. It plays perfectly fine on my computer even from my NAS over WiFi. But if I copy the video to my iPhone and try to play it in the Apple Photos app or the VLC app, I get the same stuttery playback I get on my Apple TV.

I have a similar problem. set the picture frequency to 50hz or 60hz at settings video and see if that helps.

So I’ve had the exact same issue with the appletv 4K and infuse and this video.

It’s a bitrate issue and how you mount your drive.

The only way this worked was with my Vero 4K over WiFi AC and nfs mount with fstab.

Does infuse or tvOS support fstab? Simply doing nfs mount on Vero 4K produces dropped frames with fstab it produced flawless playback.

Exact same problem here, identical to your example video. It happens only on hevc encodes for me (I use staxrip via Intel h/w encoder). These hevc files play perfectly fine on roku, xbox one, ps4 pro, pc (vlc) w/ no issue, but stutters on my apple tv 4k and ios in Infuse or native plex app. Identical to your example! I have over a hundred of these files it does it on (hevc encodes).

Can Infuse please at least add an option to force transcoding at the individual file level like the native client please? Until then it’s totally worthless to me. Either that or fix this issue that no other system has.

I’m so close to giving up on Apple and going to a roku for all my clients.