[SOLVED] XBMC black screen

I run XBMC on my AppleTV 2 with the org.tomcool.xbmc-booter option (autostart).

Anyhow, I had the problem that when XBMC launched all I saw was the splashscreen, and then it went black.

After some forensic work I figured out that the file /var/mobile/Library/Preferences/XBMC/userdata/profiles.xml was what seemed to cause this. There’s no point in deleting the file, since XBMC will recreate it immediately. So I figured that I set some owner and write permissions to it and then open it with an editor and delete all of it’s contents.

And since then I haven’t had anymore problems with that. I thought I’d share this if there are more people struggling with the same issue.


This is how I did it:

SSH to you AppleTV (ssh root@[YOUR.APPLE.TV.IP], password “alpine”)

cd /var/mobile/Library/Preferences/XBMC/userdata rm profiles.xml #(Delete the file) touch profiles.xml #(Create a new empty file) chown root:mobile profiles.xml #(Set owner of the file to user "root" and group "mobile".) chmod 600 profiles.xml #(This makes the file read/writable for user "root" only.)  

…and you’re done.