SOLVED: SSH only works on wired

I have my Apple TV 2 jailbreaked with firmware version 4.4.4 (but had same problem on jailbreaked 4.3)

For some reason I can only ssh to the box when I plug in the network cable. When on wireless I can’t ssh (or even ping it). On wireless everything else seems to work fine, I have access to Netflix etc.

IP, netmask, router, and dns is the same on both wireless and wired. I have also tried to configure with a static IP address but that did not help either.

Any clue why ssh does not work?






That sounds like your wireless router is configured to segregate the WLAN from the LAN[/quote]

Yes it sure does. But I can’t find anything in the router settings that should block for the Wireless or not route correctly between LAN and WLAN.


Also I am capable of ping’ing other wireless devices including a Mac book. It is pretty weird…


EDIT: I cannot ping from the Mac to the Apple TV 2 either (wireless -> wireless)

Well as suspected the problem was with the router. 


Under security I had to enable WPA Compatible (I use WPA2-PSK), That did the trick.