SOLVED: Seasonpass/Itunes won't restore using modified IPSW file

I’ve used Seasonpass to download & create a modified ipsw file. 

BUT

Itunes absolutely WILL NOT restore the modified file.  It fails each-and-every-time…with various errors 1600, 1604, etc…  I can (and have) attempted it dozens of times over the past two evenings… It fails every time I point Itunes to the modified file.  Yet, turn around and point it to the original file…works EVERY time.  The cadence of the restore is even different; with the original firmware file, Itunes seems to cycle the ATV2 a couple of times (judging by the connect/disconnect sound my computer plays)…but with the modified file, I never hear the disconnect sound. 

My Itunes is up-to-date, and my ATV2 is, I believe, current.  When I began this struggle two days ago, it was v4.3, but after repeated cycles through this process, it’s now running the (unmodified) firmware Seasonpass downloaded.  I’ve spent 15 hours on this, and I’m more than ready to use this thing for target practice.  I didn’t have THIS much trouble with my first ATV2 a year ago.  (and yes, it IS an ATV2)…I’ve tried a different USB port.  I’ve generated the modified IPSW file on two computers. 

 

Could someone PLEASE help me!? 

 

UPDATE:  After speaking with James directly, my problem turned out to be my iTunes version.  I uninstalled the up-to-date version and downloaded version 10.7 from the website oldapps.com, and in 15 minutes, Seasonpass (current version) accomplished what I’d spent the last two nights struggling with.  So, FLUSH your new iTunes, and install the previous version.  It will complain about the “iTunes library.itl” file being incompatible because it was created with a newer version…I just DELETED that file and restarted iTunes.  (I don’t use iTunes for anything except getting my ATV jailbroken)  Thank you SO very much, James.

 

You will need to use seasonpass version 4.3 only and create custom SP Ipsw firmware. Then use Ifaith to create a signed firmware from your ssh blogs, once you got these 2 created. You need to get the command program, you can search on google “how to create a signed jailbreak apple tv 2 firmware 4.3”.

 

Thank you for the reply.

I presume you mean I need to use the current version of seasonpass- since I don’t think it’s up to version 4.3 yet…

When  using iFaith, do I use blobs from my CURRENT version OR blobs from my beginning version (4.3 I think)?

 

Yes that what I mean you need a season pass just for 4.3 only not the newest seasonpass 101 right now it won’t work properly. You can ask around the forum maybe someone can upload that seasonpass version for you.

 

There is SO much contradictory information regarding this whole process!  This very website says I should always ensure I’m using the newest release of Seasonpass.  Now it seems, I can only use a specific version of an older copy!?  Can anyone tell me WHAT version of seasonpass is appropriate for my task- or better still, point me towards a copy? 

 

When I searched for “how to create a signed jailbreak apple tv 2 firmware 4.3” the first result has a neatly prepared set of directions, and IT specifies that I’m going to need a specific version of Apple firmware (4.4.4 9A406A)- and even supplies a link (DEAD, of course)…and a specific version (4.4.4 0.3.52.4905) of Seasonpass (again, DEAD link supplied)

Here is the link you can follow http://forum.xbmc.org/showthread.php?tid=125412